[mythtv-users] Very strange - all fonts are now square boxes...

Mark Knecht markknecht at gmail.com
Mon Dec 7 02:26:30 UTC 2009

SOLVED: emerge corefonts

I consider this an ebuild bug as the frontend is useless without being
able to read the menus, but I suspect the myth ebuild maintainers


On Sun, Dec 6, 2009 at 2:26 PM, Mark Knecht <markknecht at gmail.com> wrote:
> On Sun, Dec 6, 2009 at 1:51 PM, Mark Knecht <markknecht at gmail.com> wrote:
>> Hi,
>>   OK - this one is strange. All my theme fonts are now just square,
>> unfilled boxes..
>>   Background:
>> 1) I have three identical Pundit-R machines. I use two as frontends
>> and keep the 3rd as a spare.
>> 2) One of the frontends has a problem so I updated the spare to be
>> completely up-to-date as per Gentoo stable, so it's 0.21.
>> 3) When the updates completed mythfrontend runs fine on the spare but
>> all the theme fonts are just unfilled square boxes!
>>   OK, so I've still got one machine working correctly, but it's a
>> little out of date so I decide to update it. In the process of working
>> out some small differences between the two machine I note that the
>> working machine has no locales. For some reason I decide to give it
>> the same locales as the spare machine as I update the last 10 or so
>> packages. Now the working machine is completely up-to-date, just like
>> the spare machine. When I reboot that machine and let mythfrontend
>> start normally guess what happens? You got it - no fonts in the theme.
>>   Up until the time Myth actually starts I see all the typical
>> console fonts. Those are fine. It's only after mythfrontend starts
>> that I can see it has no fonts.
>>   Does Myth have some requirements about using or not using locales?
>> Are the fonts carried in the theme itself or are they from an external
>> package that possibly I took off the system without knowing?
>>   Why don't I have any fonts?
>> Thanks,
>> Mark
> NOTE: If it matters mythfrontend is actually working fine - I can
> watch programs even if I cannot read what they are.
> INTERESTING: Once the video is up and running I do have OSD fonts so
> it's only theme fonts that don't work. At this point I can read info
> on the program, etc., to tell what I'm watching.
> Also, I tried erasing the themecache directory and letting Myth
> recreate it but that didn't help. I also re-emerged mythtv-themes but
> that didn't help either.
> Off to see a Christmas concert played almost completely on bagpipes -
> my annual and unofficial start the to holiday season. Back in a few
> hours.
> Cheers,
> Mark

More information about the mythtv-users mailing list