[mythtv-users] Can't load latest Nvidia driver under fresh install FC12

David Krainess davidkrainess at yahoo.com
Sun Dec 6 17:34:00 UTC 2009

"What worked for me was to boot without X (runlevel 3) and with the 
"nomodeset'kernel boot parameter. "

Yeah what a hassel with F12 and being an early adopter, we take the pain for everybody else.  I had to wait for the 173 driver to be updated for my FX5200 one, just some of my notes that may be of help to others, once I got the fixed NVidia installer...

Per here, http://rpmfusion.org/Howto/nVidia, I think the updated way to deal with is "rdblacklist=nouveau" in the kernel boot line, that should take care of nouveau loading.  I think the nomodeset hack was an early stop gap measure.

Also, per here, http://forums.fedoraforum.org/showpost.php?p=1114769&postcount=1 mentions adding "vmalloc=256m" if you are using PAE.  Mine worked either way with PAE, but I left it in.

Also, for those not using a repository and installing from the NVidia binary installer, you may want to add the kernel param if you are having problems with the script complaining about building the kernel stuff, 
I.E.  "sh NVIDIA_Linux_YADAYADAYADA.run -k $(uname -r)"


More information about the mythtv-users mailing list