[mythtv-users] VDPAU package problems 0.22?

Jack Perveiler perveilerj at gmail.com
Sat Dec 5 20:24:39 UTC 2009

> Thanks Jack,
> when I do this with synaptic, it wants to remove mythtv-frontend and
> libmyth-0.22 and all the myth plugins etc, I assume this
> is normal and I just install them again afterwards?
> No, if it wants to that then something has gone wrong.   I don't exactly
know what, but here's my suggestions:

1) Make sure you're starting from "scratch".  That is, you're using stock
mythbuntu nvidia-glx-185 (+ headers + libvdpau) and stock mythbuntu mythtv
(ie not the avenard stuff first).
2) Force the version on these only: nvidia-glx-185, nvidia-185-libvdpau, and
nvidia-185-kernel-source to the 0ubuntu3 version
3) Apply them and only them.
4) THEN do the libvdpau stuff (install libvdpau1)

Steps 3 and 4 come from JYA's howto.

The basic problem is that mythbuntu's nvidia-glx-185 (the version 9 one)
provides the file /usr/lib/libvdpau.so.1 and so does libvdpau1 (which is the
point of libvdpau1).  JYA split the libvdpau stuff out of the drivers he
supplies so to make upgrading drivers independent of upgrading myth, but
unfortunately you have to work out the duplicated file kink first.

Doing step 2+3 gets you the nvidia package dependancies you need for your
CURRENTLY installed mythtv, but you'll be missing /usr/lib/libvdpau.so.1
(the package manager doesn't care about this though, as all packages have
all the dependencies they require).  They should apply cleanly (ie not
require upgrading anything else)... if not, you aren't in the state you
think you are.  Without libvdpau mythtv probably won't work real well, which
is why you have to do step 4 to get your vdpau library back.  Step 4 should
also apply cleanly (ie not require anything else, well maybe another vdpau
package with a funny name I can't remember).

I also tried just bypassing all of the 185-version-mess by going to version
190, figuring that it wouldn't have the vdpau libraries in it and I could
avoid all of this.  Due to some package dependencies though the new driver
version required a newer version of myth which in turn required package
vdpau1, which it tried to install BEFORE removing the existing 185 driver
version which then caused the two-copies-of-libvdpau.so.1 problem again.


The good news is once you're on JYA's version of the driver and have
libvdpau1 installed it's smooth sailing for everything else :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mythtv.org/pipermail/mythtv-users/attachments/20091205/918a4e15/attachment.htm>

More information about the mythtv-users mailing list