[mythtv-users] Myth Database Upgrade failed preventing 0.22 from starting on gentoo.

Michael T. Dean mtdean at thirdcontact.com
Sat Dec 5 19:36:10 UTC 2009

On 12/05/2009 02:02 PM, John Drescher wrote:
>> Did you try upgrading from the original backup?
> No. Yesterday, I had
> Server characterset:    utf8
> Db     characterset:    latin1
> Client characterset:    utf8
> Conn.  characterset:    utf8
> with 0.21-fixes. I followed the guide
> http://www.mythtv.org/wiki/Fixing_Corrupt_Database_Encoding
> to get my database to
> Server characterset:    latin1
> Db     characterset:    latin1
> Client characterset:    latin1
> Conn.  characterset:    latin1
> under 0.21 fixes still. I used 0.21 in this condition for the evening
> and then tried the 0.22 upgrade today.

Which meant that when you started using 0.21-fixes with the proper MySQL 
configuration, it was writing valid data into a database full of corrupt 
data.  That is what caused your partial corruption.

>> If you've tried both the original pre-upgrade 0.21-fixes backup and the
>> "uncorrupted" backup you show your using above, then you have partial
>> corruption, and you'll need to do:
>>  http://www.gossamer-threads.com/lists/mythtv/users/406111#406111 .
> Thanks I will look into that.

Or go back to the upgrade you made before changing the database server 
configuration and you can probably make that work.

(Then just stick last night's recordings in MythVideo or whatever.)


More information about the mythtv-users mailing list