[mythtv-users] Any Asus Aspire Revo Users Out There?

Kirk Bocek t004 at kbocek.com
Thu Dec 3 19:20:34 UTC 2009

Patrick Doyle wrote:
>>From a thread I started a couple of weeks ago (see
> http://www.gossamer-threads.com/lists/mythtv/users/408937), I have
> gleaned that the EDID contains information about whether or not the
> HDMI port on the television supports audio or not.
> I don't know how much this will help, but as some ideas for things to
> look for (as given by somebody who doesn't really know what he's
> talking about)...
> 1) Are you sure the HDMI port on your TV supports audio?  On my Vizio
> TV, I have 3 HDMI ports.  One of them is associated with a pair of L &
> R analog input audio RCA jacks.  I would guess (but don't know how to
> verify) that if I looked at the EDID when plugged into that port, it
> would say that digital audio is not supported.

All good thoughts here, Patrick.

Yes, I am sure the devices I am testing with support audio. One is a Asus
monitor normally attached to an XP box. It plays HDMI audio on the XP box
fine. The other device is a Westinghouse flatscreen TV. I have trouble
imagining that the secondary HDMI port I'm using would *not* support audio.

> 2) Are you sure that the HDMI port on your TV is correctly reporting
> that it supports audio?  Again, I don't know where to look nor what to
> look for to verify this, but perhaps others on this list can point you
> in the right direction.

That thought occurred to me just last night. My xorg.conf file is setup to
*ignore* EDID stuff so I can output a fixed resolution. This allows me to make
remote changes and reboot the MythTV host without the TV needing to be powered
on and providing EDID information:

    Option      "UseEDID" "false"
    Option      "ModeValidation"

Anyway, so last night I configured a simple xorg.conf screen that allowed the
EDID stuff through. Still no audio.

On a related thought. I wonder if there are there any Nvidia driver-related
xorg.conf parameters related to audio? So far I haven't found any.

> 3) Finally, I'll say this because it was ultimately the thing that
> took the longest for me to figure out when I tried to get HDMI to work
> (via my Radeon chipset).  I did the aplay -l thing and saw that HDMI
> audio was supported on card 1, device 3, but every time I tried
> changing one of the configuration items, I always dutifully followed
> whatever random web page I was looking at and tried stuff like
> hwplug0,3 (or whatever it's called).  I finally noticed that the card
> parameter was "0" where I was supposed to be plugging in a "1".  Moral
> of the story: it helps if you already know what you're doing when
> you're trying to figure out what you're doing.  (There's a chicken and
> the egg problem here, so the real moral might be to pay very careful
> attention to exactly what the parameters mean when you try changing X
> to Y.)

Good thought, but my aplay -l output is clearly card 0, device 3.

In answer to your second posting regarding applications, I am just trying to
get output from aplay and speaker-test right now. If I can get output from
those apps *then* I'll get MythTV working.


More information about the mythtv-users mailing list