[mythtv-users] HD-PVR: Encoding Errors Running 0.22

Jeremy Thornhill jeremy.thornhill at gmail.com
Tue Dec 1 19:33:46 UTC 2009

On Sat, 28 Nov 2009 10:34:46 -0600, David Engel <david at istwok.net> wrote
> On Fri, Nov 27, 2009 at 01:11:11PM -0500, Jeremy Thornhill wrote:
>> I'm horribly perplexed by my situation though. My device seems to just
>> arbitrarily fail to start recording properly - once it's started, it's
>> fine. The first time I start recording with it after a boot, it's
>> fine. But after that it's a total crap shoot. Sometimes the next
>> recording is fine, sometimes it will fail 2 times and then start,
>> sometimes it will fail 20 times in a row!
> This sounds like an overheating problem...

While I can't say so with certainty since I don't know how to monitor
its internal temperature, I doubt that it's heat related in my case. I
see the same failures when the HD PVR has been idle for hours after
the original successful recording and the ambient temperature is
around 55 degrees F.

> I don't know about your hdpvr, but I doubt it's your kernel config.
> Yes, the driver debug is so terse it's of little use, at least for
> this problem.
> My guess is it's one of two things.  1) It's a firmware problem.  Has
> anyone been brave enough to try the new firmware yet to see if
> it improves anything?  2) It's a subtle driver problem that doesn't
> affect the driver developers, and consequently, is not getting enough
> attention.  John P Poet is doing what he can, but the original hdpvr
> driver developer has been conspicuously abesnt from this whole
> discussion.

I did indeed try the latest Hauppauge update, but it doesn't seem to
have actually changed anything with the HD-PVR itself. dmesg still
reports '0x12' when I load the module and recordings still fail in the
same way.

At this point I've tried every voodoo computing solution I can think
of - different kernel versions, different USB cables, different USB
ports, turning the HD PVR upside down, doing the hokey pokey and
turning myself around... and the device still fails to start
recordings sporadically.

I'm starting to think that the device is defective in some subtle way
since it doesn't seem as if anybody else is seeing an identical
pattern. Has anybody tried RMAing one of these units with Hauppauge? I
wonder what the process would look like. I suppose my next step will
be to hook it up to a Windows box and see if it fails in the same
manner, since I'm guessing Hauppauge won't support its use under


More information about the mythtv-users mailing list