[mythtv-users] long delays responding to keystrokes and ir events

Darren Hart darren at dvhart.com
Wed Apr 15 04:47:32 UTC 2009

On Sun, Apr 5, 2009 at 10:03 AM, Josh Mastronarde <jmastron at gmail.com> wrote:
> On Sun, Apr 5, 2009 at 7:27 AM, Allen Edwards <allen.p.edwards at gmail.com> wrote:
>> My myth box has become almost unusable due to this delay issue.  I have to
>> reboot to get it to work at all.  What bothers me is that I have done
>> nothing to the machine except use it, no updates or fresh installs and
>> suddenly the delay problem goes from once a month to once several times a
>> show. Once I reboot, I can get through a show but before that, every time I
>> hit a key I get a multi-minute delay.
>> I have seen the patch that may address this and understand that updating the
>> fixes may also help.  However, I am not experienced enough to know what to
>> do with this patch file.  Is there a detailed set of instructions, like 50
>> numbered steps, that will fix this problem?
>> Allen
> Allen, the first step to see if you're seeing the same issue before
> attempting any fix is to run with libav logging:
> $ mythfrontend -v important,libav > some_log_file

Trying a recent episode of House recorded off my HDHomeRun, I see the following:

2009-04-14 21:29:17.823 Input #0, mpegts, from
2009-04-14 21:29:17.823   Duration: 00:59:55.5, start: 48907.282656,
bitrate: 15830 kb/s
2009-04-14 21:29:17.823     Stream #0.0[0x17ee], 1/90000: Video:
mpeg2video, yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 1001/60000, 19000
kb/s, 59.94 tb(r)
2009-04-14 21:29:17.823     Stream #0.1[0x17ef](eng), 1/90000: Audio:
ac3, 48000 Hz, stereo, 384 kb/s
2009-04-14 21:29:17.835 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
2009-04-14 21:29:18.456 Video sync method can't support double
framerate (refresh rate too low for bob deint)
2009-04-14 21:30:20.558 AFD Error: Unknown decoding error
2009-04-14 21:31:00.058 AFD Error: Unknown decoding error
2009-04-14 21:32:11.775 AFD Error: Unknown decoding error
2009-04-14 21:32:55.242 AFD Error: Unknown decoding error
2009-04-14 21:33:15.592 AFD Error: Unknown decoding error

At first pause worked fine, but once the AFD errors started happening
I could no longer pause with the remote or the keyboard.  Eventually a
few Esc presses got me back to the menu.

I tried Josh's binary patch above, but alas he appears to have been
building on 32-bit while I'm on a 64-bit installation.  I'll try to
build the lib out of svn when I get another block of time to look at
this.  Until then, if someone has already built for 64-bit, please
share :-)


More information about the mythtv-users mailing list