[mythtv-users] HDHR working but channel mapping is incorrect

Mark Knecht markknecht at gmail.com
Mon Apr 13 01:15:20 UTC 2009

On Sun, Apr 12, 2009 at 5:57 PM, Yeechang Lee <ylee at pobox.com> wrote:
> Mark Knecht <markknecht at gmail.com> says:
>> I'm thinking that possibly I've set up the wrong sort of line-up at
>> SchedulesDirect, choosing OTA vs cable???
> Yes you did; in your first message you listed an OTA lineup.

Yes, I did do that wrong, so attempting to follow the HDHR
instructions on mythtv.org I went back to choose a different lineup.
The problem I'm having now is that there isn't a lineup specific to
the HDHR, so I chose the digital cable which at least has all the
channels the HDHR can tune, but also has lots that only get tuned by a
read digital STB. Anyway, having done that Myth recognizes a few (15
maybe) channels - but doesn't map the other 85 to anything. The other
85 channels work, the HDHR can tune them, but they work with strange
channel numbers, like 100#6 instead of 9.2, etc. and don't have
program guide data yet because they don't have XMLTV IDs.

I got help offline learning a little about the XMLTV IDs, but I
haven't figured out where the right channel numbers come from so I'm

I have a busy week in front of me so in less someone can write a few
sentences that really turn on the lights for me it's likely to be
about 2 weekends before I can get back to this again. Disappointed in
myself in that I've owned this HDHR for 4 months now and it remains
utterly useless to me.

I do appreciate your help. Thanks!


More information about the mythtv-users mailing list