[mythtv-users] Skipping Issues

Jon Heizer jheizer at gmail.com
Thu Sep 18 04:56:21 UTC 2008

Hey all,

I have been having an issue since I rebuilt my myth machines a few weeks 
ago.  When ever I go to skip forward when watching a recording it will 
work fine until I have passed about the 30 minute mark or so.  After 
that skipping 30 sec or 10min will result in the video moving forward a 
sec or two, but the time showing it has moved the correct amount.

I am running knoppmyth R5.5 on my FE and MBE.  On my laptop I installed 
ubuntu repository's mythfrontend and was able to skip ok.  Since it was 
a more recent version I just compiled .21fixes as of a few hours ago on 
my backend and frontend and am still having the issue.

The seek table seems to have ~7k entries/hour/recording.  I have run DB 
checks and optimize_mythdb and both come back clean. 

When I did the reinstall, my hardware and setup changes were as follows:
    My main frontend is a completely new machine (X2 5600+ 2GB Ram)
    The master backend is the old frontend hardware (Athlon XP 2000+ 
1.5GB Ram)
    DB has been moved out of the MBE and on to a separate machine
All machines are connected via GBit wired lan.

At first I thought moving the DB was part of the cause of my issues so I 
have turned off things like starting commflag when a recording starts, 
but it is still happening.  It happens to SD, HD, before the hardware 
change and afterwards.  Basically anything that is over 30 minutes long 
is effected.

root at mythtvlivingroom:~# uname -a
Linux mythtvlivingroom 2.6.23-chw-4 #1 SMP PREEMPT Mon May 26 14:44:56 
PDT 2008 i686 GNU/Linux

root at mythtvlivingroom:~# mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 18318
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux release using_oss using_alsa using_arts using_jack using_backend 
using_dbox2 using_directfb using_dvb using_firewire using_frontend 
using_hdhomerun using_iptv using_ivtv using_joystick_menu using_lirc 
using_opengl_vsync using_opengl_video using_v4l using_x11 using_xrandr 
using_xv using_xvmc using_xvmcw using_xvmc_vld using_bindings_perl 
using_bindings_python using_opengl using_ffmpeg_threads using_libavc_5_3 

I have tried to dump my brain here but I am sure I am forgetting things 
this late so feel free to pry more.  Thanks for any help you can 
provide.  Not being able to watch anything over 30 minutes is becoming a 
pain.  Off to bed to fight another day.


More information about the mythtv-users mailing list