[mythtv-users] Problem to connect to remote backend

Ole Jørgen Legård ole at legaard.net
Thu Sep 11 09:08:29 UTC 2008


I have a FC9 PC running with the following MythTV compilation:

mythfrontend --version
Please include all output in bug reports.
MythTV Version   : 18265
MythTV Branch    : trunk
Library API      : 0.22.20080903-1
Network Protocol : 40
QT Version       : 4.3.5
Options compiled in:
 linux release using_oss using_alsa using_arts using_backend using_dbox2
using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr
using_iptv using_ivtv using_joystick_menu using_lirc using_v4l using_x11
using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw
using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads
using_libavc_5_3 using_live

This PC serves as both the master frontend and master backend and is working

Last week I installed Ubuntu 8.04 on a laptop and installed (compiled) the
same version of MythTV. I am trying to use the laptop as a frontend only.

The problem is that I can't find out why the backend refuses the connection
from the Ubuntu frontend.

Please see here for both backend and frontend logs:

The backend reports "Unknown socket closing", and the frontend freezes. The
frontend GUI does not appear until I stop the backend (Ctrl + C).

My first problem was that port 3306 (mySQL) in my firewall was closed. After
I opened it I managed to remotely log in to my database, but the same
problem persists for MythTV.

I have changed the IP addresses in mythtv-setup to the IP address of my FC9
PC (not anymore).

Can anyone please give me some pointers on what could be wrong?


More information about the mythtv-users mailing list