[mythtv-users] Getting this working should NOT be this hard!

Mark Knecht markknecht at gmail.com
Mon Oct 20 21:54:41 UTC 2008

On Mon, Oct 20, 2008 at 2:28 PM, Harry Devine <lifter89 at comcast.net> wrote:

> OK, that makes sense.  But before I do that, I figured I'd try and see
> if the new drivers worked.  So I fired up LiveTV and tried to see what I
> could see.  The Analog channel of my local ABC affiliate was the same as
> it was before.  Very slow, choppy, and with no sound at all.  The DVB
> channel for the same affiliate just shows the OSD menu all the time, a
> still frame of whatever was on the channel when it got tuned, and the
> sound sounds like a baseball card stuck in a bicycle tire.
> Here's what my frontend log shows, but I'm not sure what its telling me
> (seems like a few things wrong):


> ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL /dev/mixer
> Any ideas on what's going on here?  Are the new drivers that I installed
> earlier in the thread not really being used?
> Thanks,
> Harry

Often (but certainly not always!) these sorts of errors come after an
Alsa update. They have to do with Alsa drivers enumerating things
differently from rev to rev. Erase the /etc/asound.state file and run
alsamixer from a terminal. Set things up again and exit alsamixer.

It probably won't help with your main problem but if it's a problem on
the system it's an easy, low risk fix.


More information about the mythtv-users mailing list