[mythtv-users] Channel scan does not work

Ian Clark mrrooster at gmail.com
Fri Nov 21 14:40:42 UTC 2008

2008/11/21 Andrew Junev <a-j at a-j.ru>
[snip affinity]

> Wow! That helped, partly!
> Yes, I'm running my mythbackend on a Pentium 4 with hyperthreading.

> The proper command (at least for my Fedora system) is:
> taskset -c 0 mythtvsetup

Oooh, thanks for that too. I've been having this issue with '.21-fixes' too.
Will have to try that myself.

> This way channel scan worked as usual, at first. But then, while
> scanning a transponder with lots of channels (radio stations), my
> mythtvsetup crashed with the same error again.

Have you tried running it again? I often find just running setup again and
doing the same thing works second time round. (I assume the tuner is getting
left in some more agreeable state after the first crash, but that's a

> Perhaps it's not a 100% fix (as mythtvsetup may still crash), but it
> helped me to add the missing channels.

It sounds like a race condition, which would be less likely to show up with
a single CPU.

> Thank you very much!!!

Ditto from me too!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20081121/a852ade7/attachment.htm 

More information about the mythtv-users mailing list