[mythtv-users] Still trying to restore mythconverg database

Damian damian at gingermagic.co.uk
Tue Nov 11 14:36:27 UTC 2008

Hello again all,

I tried the previous suggestions of using the restore script, but didn't 
get anywhere. I assume it's because the backup wasn't made with the 
backup script?

I then found this page which is what I think I've done in the past:

The instructions are:

# mysql -u mythtv -p 'drop database mythconverg'                           ### drops your current database!!
# mysql -u mythtv -p 'create database mythconverg'                         ### creates a new empty database
# zcat /var/backups/mythconverg.sql.gz | mysql -u mythtv -p mythconverg    ### fills the new database with your backup

to restore a DB that Mythbuntu has been automatically backing up.

I have a completely clean install of Ubuntu that I have added Mythbuntu frontend and backend packages to it. I also have a file, "mythconverg.sql.gz" waiting to be restored.

When I try to run the above instructions, I fail at the first hurdle:

damian at MythBox:~$ mysql -u mythtv -p 'drop database mythconverg'
Enter password: 
ERROR 1045 (28000): Access denied for user 'mythtv'@'localhost' (using password: NO)

For the password, I have tried just pressing enter (blank password) and I have tried entering the Mysql password that Mythbuntu told me it was making for mythconverg. neither of them work. I've also tried running the whole thing with 'sudo' before it. Still no joy.

This must be really simple. What am I doing wrong?


More information about the mythtv-users mailing list