[mythtv-users] Video sync not working in TV out

Owen B. Mehegan owen at nerdnetworks.org
Mon May 19 04:57:38 UTC 2008

Once again I've solved my own problem. I found this page on the MythTV  


It includes this note:

"Versions of the Nvidia driver from the 8xxx series upwards use a  
built in list of modelines. You just have to set the correct modes for  
your display in the Screen subsection.

The format is simple, HorizontalResolutionxVerticalResolution_frequency
So the following line in your Screen subsection for your TV,
     Modes      "1920x1080_60" "1280x720_60" "720x480_60"
would yield 1080p, 720p and 480p outputs
     Modes      "1920x1080_60i"
would yield 1080i output.

These should be compliant for DVI and component output on all TV's so  
its probably worth trying before playing around with EDID and custom  

Using the latest drivers, I figured maybe this was all I needed. Sure  
enough, I just put in the 720p entry and everything looks sweet.  
Slight overscan that I'd like to trim down, but I can live with it.

On May 18, 2008, at 9:22 PM, Owen B. Mehegan wrote:

> OK, I found another symptom of my problem. I think this is the root of
> it. My /var/log/Xorg.log.0 has the following:
> (--) NVIDIA(0): Connected display device(s) on GeForce FX 5200 at PCI:
> 1:0:0:
> (--) NVIDIA(0):     SONY TV (DFP-0)
> (--) NVIDIA(0): SONY TV (DFP-0): 135.0 MHz maximum pixel clock
> (--) NVIDIA(0): SONY TV (DFP-0): Internal Single Link TMDS
> (II) NVIDIA(0): Mode Validation Overrides for SONY TV (DFP-0):
> (II) NVIDIA(0):     NoEdidModes
> (II) NVIDIA(0): Assigned Display Device: DFP-0
> (WW) NVIDIA(0): No valid modes for "720p"; removing.
> (WW) NVIDIA(0):
> (WW) NVIDIA(0): Unable to validate any modes; falling back to the
> default mode
> (WW) NVIDIA(0):     "nvidia-auto-select".
> (WW) NVIDIA(0):
> (II) NVIDIA(0): Validated modes:
> (II) NVIDIA(0):     "nvidia-auto-select"
> (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
> (WW) NVIDIA(0): SONY TV (DFP-0)'s EDID does not contain a maximum
> image size;
> (WW) NVIDIA(0):     cannot compute DPI from SONY TV (DFP-0)'s EDID.
> (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
> (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
> (--) Depth 24 pixmap format is 32 bpp
> That seems to indicate that, for some reason X doesn't like my custom
> modeline (quoted below). As I mentioned earlier, this exact config DID
> work with this card and monitor, up until I upgraded my system with a
> new Debian, Xorg, and Nvidia drivers. So, why is my formerly-good
> modeline not acceptable anymore?
> On May 18, 2008, at 8:27 PM, Owen B. Mehegan wrote:
>> That doesn't seem to be it. Force Full GPU Scaling is not checked,
>> checking it changed nothing. Neither did changing the GPU Scaling
>> Method to either of the other two options.
>> I notice that the nvidia-settings tool sees that the screen  
>> resolution
>> is set to 640x480, and it seems to know that my TV is widescreen (if
>> that's the meaning of the grey box that surrounds the smaller box
>> labeled 640x480). But I can't set a different/higher resolution
>> anywhere in the tool or elsewhere in the system settings.
>> When I set up X on this TV before, I had to do a lot of digging  
>> online
>> before I found some modeline settings that someone else worked out,
>> which worked for my TV. I'm not sure if nowadays there's an easier  
>> way
>> to do this. I think this TV is fairly "dumb," not like the LCD and
>> plasma displays that are basically just big computer monitors. This  
>> is
>> the relevant section of my xorg.conf:
>> Section "Monitor"
>>    Identifier     "Monitor0"
>>    VendorName     "Sony"
>>    ModelName      "HDTV"
>>    HorizSync       33.8 - 33.8
>>    VertRefresh     59.9 - 59.9
>>    Mode "720p"
>>    DotClock 37.26
>>    HTimings 960 976 1008 1104
>>    VTimings 540 542 548 563
>>    Flags "+HSync" "+VSync"
>>    EndMode
>> EndSection
>> I think I just need to get X to run the right resolution. But these
>> settings used to work!
>> On May 18, 2008, at 5:25 PM, James M. MacLaren wrote:
>>> I had something similar after upgrading to mythbuntu 0.84.
>>> I found that running nvidia-setting I had under the GPU 0 settings
>>> flat panel scaling
>>> force full gpu scaling checked, unchecking that fixed the problem
>>> I also checked gpu scaling method centered.
>>> Hope this helps
>>> James
>>> _______________________________________________
>>> mythtv-users mailing list
>>> mythtv-users at mythtv.org
>>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list