[mythtv-users] All sound out S/PDIF (was: Dolby Digital Signal indicator on Receiver)

Mark Knecht markknecht at gmail.com
Sun May 18 17:00:35 UTC 2008

On Sun, May 18, 2008 at 8:01 AM, David Snider <dsnider at thesniderpad.com> wrote:
> Michael T. Dean wrote:
>> On 05/18/2008 02:14 AM, Bob Sully wrote:
>>> Still no luck with getting stereo streams to play in mythfrontend (using
>>> the internal player for recordings, or mythmusic) if a file with Dolby
>>> Digital 5.1 sound is played first.
>>> I can play any videos, no matter what the sound codec is, within myth with
>>> this: "mplayer -fs -zoom -quiet -vo xv -ao alsa:device=spdif -afm hwac3
>>> %s").
>>> Right now, I still have to exit mythfrontend and run "iecset audio 0",
>>> then restart the frontend to play a stereo recording if I have watched a
>>> 5.1 show before it.
>> That's due to a misconfiguration of your audio system.
>>>   This is the case with my combined BE/FE machine (uses
>>> an Asus P5K-Deluxe/Wifi motherboard) and my upstairs frontend (ABit
>>> AN8-32X).  I do not have to do this if I play only recordings with DD 5.1
>>> audio.
>>> The previously mentioned work-around with a remote would be an interim
>>> fix, if I used a remote (I don't; I use RF keyboards on both machines).
>>> Has anyone yet found a fix for this within mythfrontend, so that the
>>> internal player for recordings and music will allow ALL sound to go out
>>> via the S/PDIF interface?
>> It has nothing to do with Myth.  It's completely an audio configuration
>> issue.
>>> If not...this is a feature request (or is it a bug-fix request? - not
>>> sure).  ;-)
>> System configuration bug.  :)
>> Mike
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> I recently just ran into this exact same issue.  I don't know why, but
> after I upgraded to .21, (and alsa, and my kernel, and a bunch of stuff)
> only the digital passthrough stuff worked.  I'm on gentoo and found a
> file named /etc/asound.names.  In it I found device names that I didn't
> see through the typical aplay -L.   One was named plug:spdif.  After
> going through line by line on the names running aplay -D <name>
> /usr/share/sounds/alsa/Noise.wav (an analog file).  I finally heard
> sound when I used plug:spdif.  So, in MythFrontend, I changed the
> default alsa device from ALSA:default to ALSA:plug:spdif and now
> everything works perfectly.

   I'd like to know more about this. I've been around alsa a long time
and I've never heard of /etc/asound.names. I'm also a Gentoo user and
none of my machines (8 in total) have this file so it being on your
system is a surprise to me. I know of /etc/asound.state. Did you
possibly mean that file?

   I think the intended method to get a list of devices or PCMs is to
use aplay -l or aplay -L

mark at lightning ~ $ aplay -lL
    NVidia CK804, NVidia CK804
    Default Audio Device
    NVidia CK804, NVidia CK804
    Front speakers
    NVidia CK804, NVidia CK804
    4.0 Surround output to Front and Rear speakers
    NVidia CK804, NVidia CK804
    4.1 Surround output to Front, Rear and Subwoofer speakers
    NVidia CK804, NVidia CK804
    5.0 Surround output to Front, Center and Rear speakers
    NVidia CK804, NVidia CK804
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    Discard all samples (playback) or generate zero samples (capture)
    Hammerfall DSP, RME Hammerfall HDSP 9652
    Default Audio Device
**** List of PLAYBACK Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia
CK804 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: DSP [Hammerfall DSP], device 0: RME Hammerfall HDSP 9652 [RME
Hammerfall HDSP 9652]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
mark at lightning ~ $

However this doesn't show that my system has any PCMs so I'm very
curious as to how we are getting different results. Have you set up a
virtual device under Alsa and you're getting something that way?


More information about the mythtv-users mailing list