[mythtv-users] Plextor ConvertX tuner missing sound

Thomas Pedersen tp at gvdnet.dk
Thu May 8 17:47:55 UTC 2008

Had a look at that page, but doesn't seem to solve any problem..

Audio output device: /dev/dsp			(cat /dev/urandom > /dev/dsp works!)
-- Also tried; ALSA:DEFAULT

Passthrough output device: Standard

Mixer device: /dev/mixer
-- Also tried with mixer1 and without internal controls

Capture card setup - Audio device: /dev/dsp1	(Works fine with gorecord, where I get the sound from the tuner)

I'm able to get sound with MythVideo (using Internal player), if it's any help...


Message: 8
Date: Tue, 6 May 2008 15:44:58 -0700
From: "Eric Pheatt" <eric.pheatt at gmail.com>
Subject: Re: [mythtv-users] Plextor ConvertX tuner missing sound
To: "Discussion about mythtv" <mythtv-users at mythtv.org>
	<56ad9b8c0805061544v1b05042p4081ed5326ca941e at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

On Fri, May 2, 2008 at 8:16 AM, Thomas Pedersen <tp at gvdnet.dk> wrote:

> > Hello
> >
> >  I'm having trouble with getting the Plextor tuner to work in MythTV with
> >  sound.
> >  For now I been manually compiling and installing the go7007 driver in
> >  Gentoo. (Used version 0.9.8, with a patch for the 2.6.24 kernel)
> >  The gorecord application works perfectly with both sound and video output.
> >  The tuner is configured and video works fine in MythTV, but sound does
> >  not at all. (Tried both version 0.20.2 and 0.21 of MythTV)
> >  I'm using device /dev/dsp1 which worked in gorecord (and tried both dsp
> >  and dsp for input without any luck).

Have you taken a look at the Wiki page for sound?

Which audio and mixer devices are you using for output?

> >  -- Gorecord is a program supplied with the driver, for those out there
> >  not knowing.
> >  The following error from the mythbacked seem to explain the situation:
> >
> >  ...
> >  2008-05-02 17:10:35.355 TVRec(1): Changing from None to WatchingLiveTV
> >  2008-05-02 17:10:35.357 TVRec(1): HW Tuner: 1->1
> >  [mpeg4 @ 0xb736c028]removing common factors from framerate
> >  2008-05-02 17:10:37.633 AutoExpire: CalcParams(): Max required Free
> >  Space: 2.0 GB w/freq: 15 min
> >  VIDIOC_S_CTRL:V4L2_CID_AUDIO_MUTE: Invalid argument

I think this is a normal warning and harmless for the hardware and
driver... At least it does not cause me any problems.


More information about the mythtv-users mailing list