[mythtv-users] Best kernel image/config

James Klaas jklaas at appalachian.dyndns.org
Tue May 6 14:58:52 UTC 2008

I've been struggling with a few things upgrading my myth to 0.21.
Mostly it's gone OK, although I still get tied up with compiling the
lirc modules.  <rhetorical>They don't change much, why aren't they
included in the stock distribution kernels?</rhetorical>

In any case, I am working on getting my PCTV HD 800i working and in
pursuit of that, I'd like to know if people use stock distribution
kernels or if they compile their own.  I am currently using a *buntu
distro and I'm up to Gutsy/7.10 on x86_64.  I'm currently using
linux-image-2.6.20-16-lowlatency as my kernel.  I've tried compiling
the latest hg pull from linuxtv but I consistently get "<module>:
disagrees about version of symbol struct_module" messages when I load
the necessary modules.  I've also gotten the source and recompiled the
2.6.20 kernel with the config from the lowlatency image.  I am able to
load the modules without complaints, but I get a separate set of

If I try to get a video stream from the analog side of the 800i with
mencoder, mencoder dies with a segfault, although scantv works fine
and is able to tune in all my usual channels.  I also have a bt878
card in this computer and it works fine under MythTV once, then MythTV
stops working and if I try to kill it, it becomes defunct and requires
me to reboot the computer.

Will trying a newer kernel work?  Should I just patch the 2.6.20
kernel source to include the 800i code and use that?

Thank you for any help or suggestions.


More information about the mythtv-users mailing list