[mythtv-users] Fwd: S3 Graphics UniChrome Pro IGP

Josh White jaw1959 at gmail.com
Mon Jun 30 02:23:53 UTC 2008

---------- Forwarded message ----------
From: Josh White <jaw1959 at gmail.com>
Date: Sat, Jun 28, 2008 at 9:01 PM
Subject: S3 Graphics UniChrome Pro IGP
To: Discussion about mythtv <mythtv-users at mythtv.org>

I just got myself a JetWay VIA C7 mini-ITX board.  (one of these:

I have it working, to some degree, but I think I'm having trouble with my
xorg.conf.  I can't seem to make it run the display at a reasonable
resolution.  I'm using the "openchrome" drivers, with an S-video connection
to my NTSC SD CRT TV (how's THAT for acronyms!), running on Mythbuntu 8.04.
When connected only to the TV, it seems to run happily at 640 x 480, but
earlier in the day, I seemed to "trick" it into working at a higher
resolution.  I had the machine configured in BIOS to output only to the CRT
(on the normal D-sub output).  I booted the machine into Mythbuntu, then
restarted X.  Then, for some reason that I cannot explain, both the TV and
the CRT were displaying (both were switched on, but prior to the X restart,
but the TV was blank) at a resolution of 1024 x 768.  This seemed to work
well, until I restarted the machine, set the BIOS to display only to the TV,
and tried to boot.  Now, I'm back to 640 x 480.  I imagine this is due to a
modeline issue in my xorg.conf, but I'm not not very experienced with
setting this up.  I had the same TV working with an nvidia FX5200, but the
motherboard on that machine was flaky, and I decided to give the low-power
end a try.

So that's my story, I tried to keep it succinct.  I'm also trying to get it
to use XVMC.  If anyone has experience with these boards, or TV-out to an
NTSC SDTV via S-video, I'd appreciate any tips you can provide.



I've posted my xorg.conf below:

Section "Device"
    Identifier    "S3 Graphics UniChrome Pro IGP"
    Boardname    "CN700"
    Busid        "PCI:1:0:0"
    Driver        "openchrome"
    Screen    0
    Option        "Active Device" "CRT TV"
    Option        "TVType"    "NTSC"
    Option        "TVOutput"    "S-Video"
    #Option        "EnableAGPDMA"    "1"

Section "Monitor"
    Identifier    "TV on S-Video"
    Vendorname    "Sharp"
    Modelname    "ultrasharp"
  #modeline  "640x480 at 60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
    #Gamma    1.0

Section "Screen"
    Identifier    "Default Screen"
    Device        "Configured Video Device"
    Monitor        "Configured Monitor"
    Defaultdepth    24
    SubSection "Display"
        Depth    24
        #Virtual    1024    768
        #Modes        "1280x1024 at 60" "1024x768 at 60" "800x600 at 60" "640x480 at 60"

        Modes    "720x480Noscale"


Section "ServerLayout"
    Identifier    "Default Layout"
  screen 0 "Default Screen" 0 0
Section "Module"
    Load        "glx"
    Load        "GLcore"
    Load        "v4l"
    Load        "dbe"
    Load        "extmod"
    Load        "fdbdevhw"
    Load        "dri"
    Load        "record"
    Load        "freetype"
    Load        "type1"

Section "DRI"
    Group        "video"
    Mode         0666
Section "ServerFlags"

Sorry to bump my on post, but I just wanted to make sure this was
working...does anyone on the list see this message?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080629/401c5668/attachment.htm 

More information about the mythtv-users mailing list