[mythtv-users] MythTV/cron interaction?

Mark Greenwood fatgerman at ntlworld.com
Sat Jun 28 21:15:14 UTC 2008

On Saturday 28 June 2008 20:51:50 Nick Morrott wrote:
> On 28/06/2008, Mark Greenwood <fatgerman at ntlworld.com> wrote:
> >  But this wasn't working - just nothing was happening, nothing from cron in any logfile. Then I found that 'ps -ae | grep cron' returned nothing. Strange. There were 'S83cron' symlinks in all the relevant rc*.d directories. Starting cron from the command line worked fine. So I removed cron (update-rc.d -f cron remove) and re-added it (update-rc.d cron defaults 83). Reboot. Still no cron. So I tried removing it again and trying 'update-rc.d cron defaults 11'. Reboot. Now I have cron, and my shutdown crontab works. But now myth won't record any programs. Live TV is OK but all scheduled recordings fail (Canceled recording (Recorder Failed) in the myth logs). Put cron back to 83 and myth works but cron doesn't.
> >
> >  Can anybody explain what's going on? And also if there's a better way to get my box to shut itself down I'd be grateful.
> First, see the MythWelcome
> (http://mythtv.org/wiki/index.php/Mythwelcome) and Startup/Shutdown
> (http://mythtv.org/wiki/index.php/Shutdown_Wakeup) details on the
> wiki, as these provide a more MythTV-centric way to shutdown your box.

Thanks, I'll investigate that.

> Are there any differences in your dmesg/syslog output at startup when
> the shutdown crontab is disable/enabled? If you run mythbackend with
> extra verbosity (see mythbackend -v help), is the 'Recorder Failed'
> message any more explanatory?

Thanks, I always forget to check syslog - there is absolutely nothing from cron in syslog or any other log, regardless of whether that crontab is enabled or not. But I can run cron's init script from the command line once everything has booted, and it starts writing to syslog and will run scheduled jobs. Myth also records correctly when I do this. So perhaps the 'recording failed' thing is a red herring caused by me playing with the startup script ordering and my real problem is that, for some reason, cron just doesn't want to start at boot on my system.



More information about the mythtv-users mailing list