[mythtv-users] MythTV/cron interaction?

Mark Greenwood fatgerman at ntlworld.com
Sat Jun 28 19:23:31 UTC 2008

Is there some strange way in which myth interacts with cron? I've just tried something which I've done successfully before on non-myth installations but on my myth box it didn't work and appeared to break my myth backend.

I'm running mythbuntu 8.04. I wanted to add a cron job to shut the myth box down in the morning. My usual way of doing this is:
crontab -e
0 2 * * * /sbin/shutdown -h now
save the file.

But this wasn't working - just nothing was happening, nothing from cron in any logfile. Then I found that 'ps -ae | grep cron' returned nothing. Strange. There were 'S83cron' symlinks in all the relevant rc*.d directories. Starting cron from the command line worked fine. So I removed cron (update-rc.d -f cron remove) and re-added it (update-rc.d cron defaults 83). Reboot. Still no cron. So I tried removing it again and trying 'update-rc.d cron defaults 11'. Reboot. Now I have cron, and my shutdown crontab works. But now myth won't record any programs. Live TV is OK but all scheduled recordings fail (Canceled recording (Recorder Failed) in the myth logs). Put cron back to 83 and myth works but cron doesn't.

Can anybody explain what's going on? And also if there's a better way to get my box to shut itself down I'd be grateful.


More information about the mythtv-users mailing list