[mythtv-users] ISO playback still broken in 0.21-fixes?

scram69 scram69 at gmail.com
Tue Jun 24 05:12:40 UTC 2008

On Mon, Jun 23, 2008 at 10:27 AM, scram69 <scram69 at gmail.com> wrote:
> On Sun, Jun 22, 2008 at 5:16 PM, Todd D. Volz <todd at stir.org> wrote:
>> I'm running .21 fixes (I don't have the specific version at my fingertips)
>> on OpenSuse 10.3, unstalled everything from pacman I beleive and am having
>> no problems.
>> In the plain .21 I had problems with the dvd ISO movies jumping around and
>> skipping when using the internal player and using a menu on a dvd was a
>> carpshoot, once I updated to .21-fixes playback smoothed out and the menus
>> worked as they should.
>> Sounds like you have some dependencies that are a little old, but that's
>> just my first guess with the info that you have provided.
> The dependent packages are what's installed by osx-packager.pl, so I
> don't have much control over that.  I've never had a problem playing
> back ISOs with 0.20, 0.20-fixes, or 0.20.2; presumably those
> dependencies are older than those currently in osx-packager.pl.
> I realize I need to go back and run with -v playback flag to see if I
> can get a little more info...

Well, I tried -v playback, but didn't get any more info:

2008-06-23 21:25:24.178 TV: Attempting to change from None to
2008-06-23 21:25:24.178
OpenFile(dvd:/var/lib/mythtv/videos/Kids/findingnemo.iso, 12)
libdvdnav: Using dvdnav version 0.1.10-xine from http://xine.sf.net
libdvdread: Encrypted DVD support unavailable.
libdvdread: Can't stat /dev/dvd
No such file or directory
libdvdnav: vm: faild to open/read the DVD
2008-06-23 21:25:24.179 Failed to open DVD device at /dev/dvd
2008-06-23 21:25:24.179 RingBuf(/dev/dvd): CalcReadAheadThresh(4000 KB)
                         -> threshhold(64 KB) min read(32 KB) blk size(64 KB)

What's really puzzling is that the frontend is clearly opening the
correct .iso file in /videos/.  It can play non-.iso files in /videos
just fine.  What the hell is it trying to do in /dev/dvd?  There isn't
even a /dev/dvd in osx - it's called /dev/rdisk0 !

That, and iso playback worked just fine under 0.20.2.....

More information about the mythtv-users mailing list