[mythtv-users] Mandriva 2008.1 Hauppauge MCE pvr-150 remote control assistance please.

Mark Adams madams9 at gmail.com
Mon Jun 23 05:58:01 UTC 2008

Please forgive this if it's a dupe.  I'm having some trouble getting mail up
to the list.

I have a Mythbox working pretty well under Mandriva 2008.1 (kernel,
but I'm stumped at getting the remote to work.  I'd like any wisdom the
group may have about this.  Also, based on my reading of this list, I'm
wondering about the option of simply purchasing another remote and avoiding
more pain.  At any rate, on to my problem:

The remote is a USB infrared device. It looks like a black version of the
Xbox 360 remote control. It is identified here


as the Phillips eHome version 2, model 1069. My hardware list in Mandriva
Control Center agrees that the receive plugged into the USB port is the

Vendor: ‎Topseed
Description: ‎eHome Infrared Transceiver
Media class: ‎
Bus: ‎USB
Bus PCI #: ‎2
PCI device #: ‎2
Vendor ID: ‎0x1784
Device ID: ‎0x0001
Sub vendor ID: ‎0x0000
Sub device ID: ‎0x0000
Module: ‎lirc_mceusb2

It appears to be loading up but neither the hardware list nor lsusb actually
identify the device. The hardware list puts it at the bottom under "Unknown
Others" and when expanded shows the device as "eHome Infrared Transceiver".

I've done a lot of Googling and tried a few different configs. At this point
lircd won't even start on the box. This might be because I have things so
munged up from trying to make it all work. At one point it was starting then
almost immediately dying without throwing an error. Nothing is showing up in

Here is my /etc/lircd.conf:

# From http://lircconfig.commandir.com/lircd.conf/?viewremote=139
# on 6/20/2008
# For Hauppauge IR remote model 1069 using module lirc_mceusb2

begin remote
name mceusb2
bits 16
eps 30
aeps 100
header 2667 889
one 444 444
zero 444 444
gap 105000
toggle_bit 22
pre_data_bits 21
pre_data 0x37FF0

begin codes

# no e2,e3
Blue 0x00007ba1
Yellow 0x00007ba2
Green 0x00007ba3
Red 0x00007ba4
Teletext 0x00007ba5
Radio 0x00007baf
Print 0x00007bb1
Videos 0x00007bb5
Pictures 0x00007bb6
RecTV 0x00007bb7
Music 0x00007bb8
TV 0x00007bb9
Guide 0x00007bd9
LiveTV 0x00007bda
DVD 0x00007bdb
Back 0x00007bdc
OK 0x00007bdd
Right 0x00007bde
Left 0x00007bdf
Down 0x00007be0
Up 0x00007be1
Star 0x00007be2
Hash 0x00007be3
Replay 0x00007be4
Skip 0x00007be5
Stop 0x00007be6
Pause 0x00007be7
Record 0x00007be8
Play 0x00007be9
Rewind 0x00007bea
Forward 0x00007beb
ChanDown 0x00007bec
ChanUp 0x00007bed
VolDown 0x00007bee
VolUp 0x00007bef
More 0x00007bf0
Mute 0x00007bf1
Home 0x00007bf2
Power 0x00007bf3
Enter 0x00007bf4
Clear 0x00007bf5
Nine 0x00007bf6
Eight 0x00007bf7
Seven 0x00007bf8
Six 0x00007bf9
Five 0x00007bfa
Four 0x00007bfb
Three 0x00007bfc
Two 0x00007bfd
One 0x00007bfe
Zero 0x00007bff

end codes

end remote

I have tried various likely-looking drivers from the list in "lircd
-driver=?" but nothing worked. At one point, I was getting lircd to start
and live long enough to try to read activity with "irw", but at this point,
I'm kind of burnt on it and need some fresh ideas.

And here is my /etc/sysconfig/lircd file:

# Customized setings for lirc daemon

# The hardware driver to use, run lircd --driver=? for a list


# Hardware driver module to load

# The device node that communicates with the IR device.
# if you are using lirc_serial, set DEVICE to /dev/ttyS[0-9]
# where 0-9 is the serial port your IR receiver is plugged

# with devfs enabled

# without devfs

# Serial port for the receiver (for serial driver)
# COM1 (/dev/ttyS0)
#DRIVER_OPTS="irq=4 io=0x3f8"

# COM2 (/dev/ttyS1)
#DRIVER_OPTS="irq=3 io=0x2f8"

# COM3 (/dev/ttyS2)
#DRIVER_OPTS="irq=4 io=0x3e8

# COM4 (/dev/ttyS3)
#DRIVER_OPTS="irq=3 io=0x2e8"

According to lsmod, modules are loading:
# lsmod|grep lirc
lirc_i2c 9476 0
i2c_core 19360 16

lirc_mceusb2 12516 1
lirc_dev 12324 2 lirc_i2c,lirc_mceusb2
usbcore 121932 8

Any idea what I'm missing here?

Can someone point me in the right direction on this?


Mark E. Adams

Random Musing: It is your concern when your neighbor's wall is on fire.
        -- Quintus Horatius Flaccus (Horace)

Mark Adams
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080622/6aa7acd4/attachment.htm 

More information about the mythtv-users mailing list