[mythtv-users] nuvexport fails with'mythtranscode had died early

John Veness John.Veness.myth at pelago.org.uk
Sun Jun 22 10:38:41 UTC 2008

http://www.gossamer-threads.com/lists/mythtv/users/333726 said:

 > I'm using Ubuntu Hardy with MythTV installed from the latest packages 
and both nuvexport and ffmpeg compiled from latest source (NOT PACKAGES) 
as per the various HOWTO's that google turned up. I'm trying to use 
nuvexport to export UK radio programs recorded from DVB-T (Freeview) to 
MP3. I have had this all working fine on a machine running Feisty up 
until a recent hardware failure - I've been successfully producing MP3's 
like this for over a year. This just makes my current difficulties more 
frustrating! Nuvexport starts up just fine. I then hit a number to 
select a show from the list and the terminal window goes blank. If I 
wait and do nothing then it stays blank. If I hit [return] then i get 
the following:
> Use of uninitialized value in concatenation (.) or string at /usr/local/share/nuvexport/nuv_export/ui.pm line 320, line 1.
> followed by the 'You have chosen to export 1 episode:' prompt. If I then select 'c' to continue the following happens:
> Choose a function, or episode(s) to remove: c
> Where would you like to export the files to? [/home/user]
> Enable Myth cutlist? [Yes] no
> Audio bitrate? [128]
> Now encoding: The Doppelganger: Untitled
> Encode started: Sat May 10 12:29:49 2008
> Waiting for mythtranscode to set up the fifos.
> mythtranscode finished.
> mythtranscode had died early:
> 2008-05-10 12:29:49.261 Using runtime prefix = /usr, libdir = /usr/lib
> 2008-05-10 12:29:49.262 Empty LocalHostName.
> 2008-05-10 12:29:49.275 New DB connection, total: 1
> 2008-05-10 12:29:49.280 Closing DB connection named 'DBManager0'
> 2008-05-10 12:29:49.281 Enabled verbose msgs: important
> 2008-05-10 12:29:49.285 New DB connection, total: 2
> 2008-05-10 12:29:49.310 Using protocol version 40
> 2008-05-10 12:29:50.009 NVP: Unable to initialize video for transcode.
> 2008-05-10 12:29:50.009 Unable to initialize NuppelVideoPlayer for Transcode Segmentation fault
> !!! process 16231 complete: 139 !!!
> Cleaning up temp files.
> Cleaning up child processes.
> I've googled this thing for a week. I've tried with fresh installations of mythbuntu and mythdora. I've tried building mythtv from source. I've tried everything I can think of and this thing is driving me crazy!!!!!
> I know I'm making a stupid mistake somewhere - but I'd REALLY appreciate some help with this.
> Yours hopefully,

I'm having exactly the same problem with MythTV on Hardy (using the 
weekly-fixes packages). I used to be able to nuvexport DVB-T radio 
programs to mp3 in previous versions (sorry I can't be more specific), 
but can no longer, with exactly the same behaviour and error messages as 
above. I *can* nuvexport the audio track of DVB-T TV programs to mp3, 
but not DVB-T radio.

Any ideas?



John Veness, MythTV user, UK, DVB-T

More information about the mythtv-users mailing list