[mythtv-users] Fwd: ALSA surround51: stopped working, device or resourse busy

backuppc at sundquist.imapmail.org backuppc at sundquist.imapmail.org
Sat Jun 21 16:28:18 UTC 2008

I have an Intel HDA sound card (well, on the motherboard).  Mythbuntu
(still 7.10 here) set it up well, and I get good 5.1 surround sound from
it.  It even worked with MythTV, at least for a while.  It stopped
intermittently (once just while I was fast forwarding through a
commercial), now for good.  I searched around on the net for solutions. 
The first fix I got was to mute the line in using ALSA mixer.  But that
fix stopped working.

The log says:

2008-06-20 21:40:56.201 AFD: Opened codec 0x88df5e0, id(AC3) type(Audio)
2008-06-20 21:40:56.202 Opening ALSA audio device 'plug:surround51:0'.
2008-06-20 21:40:56.203 AudioOutput Error:
snd_pcm_open(plug:surround51:0): Device or resource busy
2008-06-20 21:40:56.203 NVP: Disabling Audio, reason is:
snd_pcm_open(plug:surround51:0): Device or resource busy

I get same results using different values for the sound system (e.g. I
tried ALSA:surround51:CARD=Intel,DEV=0 based on my aplay -L results)

I am not sure what is keeping this device or resource busy.

Note, I installed KDE packages with the Mythbuntu install, don't know if
that makes a difference.  artsd is running.  But that was always running
as far as I know (surround was working for a few weeks).  I tried
turning off the "sound system" in the KDE system settings but it didn't
make a difference.

Sound is no problem in mythtv using ALSA:default, but is just 2 channel.

This is with the internal sound card, not SPDIF (motherboard doesn't
have a SPDIF out jack or header).

Anybody have any suggestions?



More information about the mythtv-users mailing list