[mythtv-users] What is wrong with my drive?

Johnny Russ jruss at mit.edu
Thu Jun 19 19:05:41 UTC 2008

Let me give a little background on how I got into my current conundrum. I
got a couple of 250 GB SATA drives from a friend and I wanted to put them in
my backend for extra storage. My backend is an old PIII 1 GHz Dell computer
with two 160 GB PATA drives. I had to use a SATA to PCI card. I did a clean
install and was using all of the storage in a RAID/LVM volume. I finally got
everything set up and going but my system kept crashing. I tracked it down
to some kernel bug with SATA to PCI cards that has been around for a while
and is unlikely to be fixed soon. So I took out the 250 GB drives and figure
I will put them to good use elsewhere. I have my system all backed up so I
will just get it back to how it was. Simple right? :).

I got everything set back up on the two 160 GB drives. My system started
crashing again, but in a different way. It won't reboot (invalid disk
error). I get things up with system rescue CD. One of the drives indicates
there is no parition structure and gparted indicates that it is a 2048 TiB
drive (I wish ;) ). Fdisk says it is -2042.... MB (yes that is a minus).
This must be some default largest possible value I am guessing. At first I
assume my drive is hosed. I run testdisk to see if it can find the
partitions. It is giving me read errors on every cylinder as it is
searching, so I back out of that with out finishing the search or making any
changes. Voila! now gparted can see the drive fine with the correct size and
partitions. I run fsck.xfs/e2fsck and everything is fine.

The next day things crash exactly the same way. This time I realize the
drives are connected to my motherboard in a different order than they were
before. I have an old motherboard that has the 137 GB LBA limit issues. So I
put the drives in the other order and copy my /boot and / partitions over to
the good drive how things were before this whole mess started. I thought
there might be an issue with the 137 GB limit. I remember previously that I
was OK as long as I don't have any partitions larger than 137 GB. I set up
things again but I split the storage up in to smaller partitions and then
put them all into one logical volume with LVM. This time system doesn't
crash anymore because the system files are on the good drive. But the LV
goes down eventually and the bad drive is showing up with no partitions and
2042 TiB. Searching for a minute or two with testdisk and then quiting will
frequently bring the drive back from oblivion. I don't know why.

I ran smartctl --test=long and badblocks -svw on the drive and they came up
with nothing. So I don't think the drive is actually faling. At least not in
any normal way that I am familiar with.

Smart indicates that it passes it self test when I tell it to run while the
drive is in the messed up state. But  it does complain about some Smart data
structures and the drive information is garbled. Here is what smartctl -a
gives me when things are messed up:

Warning! Drive Identity Structure error: invalid SMART checksum.
Device Model:     Ma|tor$6]160T0$ $ $ $ $ $ $ $ $ $ $ $ $
Serial Number:    ]45L\HWE$ $ $ $ $ $
Firmware Version: ]AV45BW0

When I bring the drive back to life by searching with testdisk, the smart
data is back:

Model Family:     Maxtor DiamondMax Plus 9 family
Device Model:     Maxtor 6Y160P0
Serial Number:    Y41LXHWE
Firmware Version: YAR41BW0

I realize this is a little OT but I haven't seen anything like this, and I
know some people around here have probably put large drives into old
systems. Any ideas what is going on or what I can do about it?

I would rather not have to explain to my wife why MythTV is broken again
because I was 'fixing' things.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080619/bdbc30db/attachment.htm 

More information about the mythtv-users mailing list