[mythtv-users] All day and I am nowhere

Allen Edwards allen.edwards at oldpaloalto.com
Wed Jun 18 09:26:19 UTC 2008

All day and I am not close to where I was on my prototype machine.  My
new Asus M3A, Asus 6200, AMD 5400+, air2pc 0.2, Mythbuntu 8.04 machine
has a few problems.

I have searched far and wide (for almost all of the last 20 hours).  I
have been down so many dead ends -- "just modify xxx.conf", but there
is no xxx.conf on my computer...  I searched the archives and googled
myself nuts.  I even got help from someone at Google.  (disclosure: I
am not the person with my name that works at Google).

1) Latest problem is that I cannot get sound out both S/PDIF and
Analog at same time.  I did this on my P4 prototype but I can't get it
to work on the new system.  Basically, when I set it up the way I did
with the P4 system, I get S/PDIF out but the analog goes mute.   That
setup in myth general setup is:
Audio output ALSA :default
Passthrough:  ALSA: iec958{...
Enable AC3
Enable DTS
No agressive
No internal volume.

Now, this sound card (on board) says it can send different sources to
the various outputs such that one thing can go to the S/PDIF and
another to the analog outputs.  I tested this and sure enough I could
have the TV going to the S/PDIF and a "sound-test" signal to the left
and right analog speakers.  I think the P4 system sent the same signal
to both outputs.

I cannot find a setting or myth setup that will give me analog audio
when S\PDIF bypss is selected.

The chip is an Azalia chip (AC'97 replacement).

Anyone know how I can get both analog and S/PDIF out of Mythbuntu?

This was the reason I bought this MB!  What a pity if it won't work.

2) My air2pc card takes 5 minutes to lock the first time after a boot.
 After that, it works fine.  This card did not do this in the P4

3) When the air2pc card is installed, 30% of the time the computer
boots up in low resolution mode.  It is not recognizing the monitor.
This is the same monitor that worked fine  with the P4 system.  With
the air2pc card removed, I did 7 boots in a row without a problem.
First boot after putting the card back and it failed.  I tried to
upgrade to the latest Nvidia driver (173.14.09) but that doesn't work.
 I then ran Envyng, uninstalled, installed, and ended up where I
started at 169.12.  Apparently that is the latest Ubuntu version.  So
I gave up that idea. I upgraded everything else in the system, but no
change.  I might know how to work around this if a real solution
cannot be found. I say might because I am building a dual monitor
machine and if the card can't recognize the monitors, how is it going
to know which profile to assign???

4) On shutdown, I see error messages "NetworkManager:
nm_dbus_signal_device_status_change: assertion
'cb-data->data->dbus_connection' failed" I searched this one and some
people say to ignore it but I list it here in case it is connected
with the others.  Maybe just a harmless bug, don't know.

In less than 4 hours, I will have worked on this for 24 hours taking
time out to go for a short run, shop for food, and eat -- nothing

I am about to throw the damn thing through the window and forget it.
Time for sleep.  Got more important things to do tomorrow.

Seriously, help on any of these problems would be appreciated.


More information about the mythtv-users mailing list