[mythtv-users] Can't change channels Part II

peter at vanderwal.us peter at vanderwal.us
Fri Jun 13 19:41:07 UTC 2008

Ok I reloaded MythDora 5 on a clean disk, and I'm having the same problem.

It won't change channels, everything worked before with M4.

I tried changing settings in a few spots and made some progress.
Under TV Settings>Playback OSD
I disabled "Always use browse mode when changing channels in live TV".
Now the up/down buttons change channels, but I still can't punch in a
channel number or change channels from the OSD.  Same as before, it
freezes like it's changing channels but does.

Using the up/down buttons gives some different errors in the DB however:

GetChannelData() failed because it could not find channel number
'NextChannel 0' in DB for source '1'
ChannelBase(1): IsTuneable(S-Video 1, NextChannel 0) Failed to find
channel in DB for input '1'
ChannelBase(1) Error: Setting start channel "NextChannel 0' failed, and we
failed to find any suitable channels on any input.
Channel(/dev/video0) Error: GetCurrentChannelNum(244) Failed to find channel
Channel(/dev/video0)::TuneTo(244): Error, Failed to find channel.
Initializing Serial Port....
ret_pid(17735) child(17735) status(0x0)
External Tuning program exited with no error
Finished recording KGUN 9 News at 6:00PM: channel 9
scheduler: Last message repeated 2 times: Finished recording Nightly
Bussiness Report: channel 6
scheduler:Finished recording: KGUN 9 News at 6:00PM: channel 9

So, obviously mythtv has no problem using the external channel changer
when it wants to, and part of it knows what channel it's on since it's
pulling info from the channels schedules.
I think this 'NextChannel 0' crap is the problem.  Fwiw channel 244, as
seen above, is the "preset tuner to" setting in the "Input connections"
section of the backend setup.

Any ideas?  Thanks in advance.

More information about the mythtv-users mailing list