[mythtv-users] Mythback suddenly started can't connect

mat mat at lessermatters.co.uk
Wed Jun 11 21:03:36 UTC 2008

Hi folks,

Again, I have problems. This happened over the weekend - I _think_ my OS 
partition was full to the brim. Basically I noticed something didn't 
record, tried to watch live TV and it couldn't connect to backend. So I 
have tried running:

mythbackend -v all

..and I get:

2008-06-11 21:59:09.175 Using runtime prefix = /usr
2008-06-11 21:59:09.198 New DB connection, total: 1
2008-06-11 21:59:09.200 Unable to connect to database!
2008-06-11 21:59:09.200 Driver error was [1/2003]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to MySQL server on '' (111)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2008-06-11 21:59:09.252 DB Error (KickDatabase):
Query was:
No error type from QSqlError?  Strange...
2008-06-11 21:59:09.302 Failed to init MythContext, exiting.
2008-06-11 21:59:09.304 SSDPCache - Destructor
2008-06-11 21:59:09.305 UPnpDeviceDesc - Destructor

I can log into the database mysql -u root mythconverg -p and list all 
the tables, so the DB seems to work. I can also log in using the 
username and p/w stored in /etc/mythtv/mysql.txt.

Please help! I almost decided to re-install the entire OS (not something 
I want to do - it's been happily running for about 3 or so years!)

Any help, would be mega-appreciated,


I can

More information about the mythtv-users mailing list