[mythtv-users] Help! Can't change channels after upgrade

peter at vanderwal.us peter at vanderwal.us
Wed Jun 11 10:58:56 UTC 2008

> On 06/11/2008 02:07 AM, peter at vanderwal.us wrote:
>>> http://www.gossamer-threads.com/lists/mythtv/users/264034#264034
>> I've done that, twice, no joy.
> Well, until you fix the problem whose error was in your original post
> (copied here, for reference):
>> Channel(/dev/video) Error: GetCurrentChannelNum(244): Failed to find
>> Channel
>> Channel(/dev/video)::TuneTo(244): Error, failed to find channel
> Myth won't work.  I'm guessing that each time you Delete all video
> sources, you reconfigure them and make the same configuration mistake
> each time.  Figure out what mistake you're making when configuring video
> sources/input connections/channels and Myth should work just fine.

Video source is the latest version of tv_grab_na_dtv.  Not a whole lot of
configuration choices.
I run tv_grab_na_dtv --configure
then input my timezone and area code, then pick the channels I want.
Then I run Mythfilldatabase --manual
it sees the channels I've selected, I put in the same numbers for it as
the channel number.
It loads up the channels fine.  I can see them in the channel editor of
mythtv setup.  I can see them in mythweb.  I can see them in the OSD. I
can see them under scheduling and pick programs and set them up for
Under mythweb, the xmltvid matches the channel number, just like I set it
up in mythfilldatabase --manual.

I just can't change channels.  Recording also fails because it can't
change channels.

If you can give me a hint as to what part of the configuration I'm
screwing up, I'd appreciate it.

I'm thinking it might have something to do with the frontend, but not sure
and I can't see any problems in the frontend setup either.

More information about the mythtv-users mailing list