[mythtv-users] XvMC does not work on 720p!?

Comments comments at mecworks.com
Tue Jun 10 00:26:33 UTC 2008

Hi, I recently tried both an nvidia GeForce FX 5700LE and a Geforce 6200 
and have been pretty much unable to get XvMC working at all.

I'm using OpenSuse 10.3 i586 with mythtv 0.21-9 from Packman and I'm 
using the 173.14.05 NVidia drivers from NVidia's site (I have also tried 
the 169 ones from the opensuse nvidia repository with the same results). 
  I have a projector that supports native 720p and it displays perfectly 
using the DVI out on either card.  However, I have not been able to get 
XvMC working with either card except for once (and it hasn't worked since).

The one time it did work, I was using the 5700LE and I had the output 
(1024x768) going to an LCD panel using the VGA out.  It worked using 
mplayer for a couple tries.  Then once I got it working, I thought it 
was all good, switched back to the projector in 720p, and have not been 
able to get it working again since.

I have the following in the Device section of the xorg.conf:

     Option         "NvAGP" "1"
     Option         "UseEvents" "true"
     Option         "XvmcUsesTextures" "false"

and I have libXvMCNVIDIA_dynamic.so.1 in  /etc/X11/XvMCConfig

So, I'm really stuck on this whole thing and don't know what to do. 
Apparently, XvMC *can* work. I'm wondering if it will work with 720p 
native or if I have to use a "standard" computer resolution and if 
there's anything else I am missing to get this working.


More information about the mythtv-users mailing list