[mythtv-users] osx-packager doesn't build Qt?

scram69 scram69 at gmail.com
Sun Jun 8 23:18:26 UTC 2008

I just got the latest version of osx-packager.pl from
I was under the impression that the script downloaded and built Qt as
one of the dependencies for Myth.  However, running it under Xcode
tools 2.5 (for OS X 10.4.11), I get the following error message:
ERROR! You must have a threaded Qt installed to compile MythTV.
[osx-pkg] Failed system call: " ./configure
--prefix=/Users/mini/buildmyth/.osx-packager/build --disable-distcc "
with error code 1
Died at osx-packager.pl line 894.

I would attach the config.err file, but the list prohibits 40K - it's about 75K.

Before I go find, compile, and install Qt separately, I just wanted to
get confirmation that this is the intended procedure, as I originally
got the impression that the osx-packager.pl script was supposed to
handle dependencies, including Qt.  Is this what most folks building
on OS X do?
Is there a preferred version of Qt (in searching, I found outdated
posts referring to problems with older (<4.x) versions of Qt, but it
is difficult to know if this info is still applicable)?


"The Linux of transportation."

More information about the mythtv-users mailing list