[mythtv-users] After Suspend-to-ram Malformed Network Packets

Brian Foddy bfoddy at visi.com
Sun Jun 8 18:09:48 UTC 2008

I have a Gigabyte GA-MA78G-DS3H motherboard with onboard
Realtek 8111C 10/100/1000 onboard network.  Mandriva auto detected
the network using the r8169 driver.

I've been trying to get STR (S3) working and I'm so close, but
yet so far.  BTW, suspend to disk (s4) works perfectly.

Using s2ram -f, with X running, the machine goes down gracefully,
and hitting the power button brings it back, X still working, keyboard,
mouse, everything working except the network.

I've tried  downing the network, even unloading the r8169 module before,
nothing helps.  ifconfig shows the network as up with the correct
static ip address (no change if I use DHCP).

As I started digging into it more, if I run wireshark on the machine when
it comes back, and ping it from another machine, wireshark reports
the packets coming in, but they are all labeled "Malformed Packet".
Everything is "Malformed Packet".  Same test using STD works fine.

I'm running Mandriva 2008.1 with an upgrade/custom kernel.  I have noticed a driver on the Realtek web
site, but it doesn't build correctly.

Does anyone have any ideas, or suggestions of how to 
continue diagnosing the problem?


More information about the mythtv-users mailing list