[mythtv-users] errors when running perl scripts

Matt Emmott memmott at gmail.com
Thu Jun 5 23:45:00 UTC 2008

On Wed, Jun 4, 2008 at 9:47 PM, Carl Fongheiser <carlfongheiser at gmail.com>

> Have you tried connecting to MySQL from the command line?

Yes, I run this: matt at magic:~$ mysql -u mythtv -h localhost -p mythconverg
And enter the password, and then I'm in.

> So it's all variables - Where the heck do I find where it's getting its
>> settings? I'm running mythtv .21 on Mythbuntu 7.10. Thanks!
> It pulls them out of $MYTHCONFDIR/config.xml, if MYTHCONFDIR is defined.
> Otherwise, it uses $HOME/.mythtv/config.xml.
> If that doesn't work, it tries to use UPnP.

I found  3 config.xml's:

The only one with any relevant info is the /usr/share file which contains
the following:


I changed a couple of the lines to the following:


And so far it hasn't helped. Do I need to restart anything for the changes
to take effect?

> It's not really bad code to read.

If you know Perl it's not bad. I can barely keep up with XML files, but I'm
trying to learn as I go. Thanks for the help thus far and any more would be
greatly appreciated.

- Matt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080605/22b15b25/attachment.htm 

More information about the mythtv-users mailing list