[mythtv-users] Could realtime commercial flagging cause hard lockup/freeze/hang?

finlay finlay at moeraki.com
Wed Jun 4 03:02:54 UTC 2008

Greg Grotsky wrote:
> Hello all,
>   I've been a mythtv user for a few years.  My configuration is a 
> single system frontend/backend.  Since it's inception I have been 
> using realtime commercial flagging and it has worked very well.  
> However, I recently updated my mythtv svn tree (to 17392 from an 
> update 5/3/08) and every once in a while the system completely hangs.  
> It hangs to the point where the magic Alt-SysRq-REISUB does not reboot 
> it, no SSH, no three-fingered-salute, no nothing.
>   I get nothing in my logs (FE, BE, syslog, messages, etc) and it 
> appears to happen when recording and doing commercial detection.  It 
> froze three times over three days and I started to worry.  I 
> completely disabled commercial detection and it worked for two days 
> straight so I decided to turn comflagging back on because the queue 
> was huge.  It detected all the commercials in the recorded shows and 
> the next day while recording and comflagging it died again!  So I 
> turned off the realtime comflag option and it has been working for two 
> days now without a hang.
>   I thought maybe it was a memory issue so I sacrificed a few shows 
> and ran memtest86 overnight; it completed 12 cycles and didn't report 
> any errors.  None of the information I have proves anything but so far 
> it's looking like some update done in may to the comflagger is the 
> culprit.  Anyone have information that supports or debunks this 
> theory?  It's not a big loss to not have realtime comflagging but it 
> was a cool geek thing to tout. :)
I had something similar happen to my system recently while using 
realtime commflag. After much futzing around with hardware I finally 
realized that the OS seemed to be the problem. I had upgraded the system 
from Ubuntu 710 to 804 a few weeks before and everything seemed OK but 
then the problems started - system lockup when recording and 
commflagging but working fine otherwise. I finally installed a clean 
version of Mythbuntu 804 and everything has been working great for the 
last 2 weeks.

More information about the mythtv-users mailing list