[mythtv-users] Could realtime commercial flagging cause hard lockup/freeze/hang?

Greg Grotsky spikeygg at gmail.com
Wed Jun 4 02:17:59 UTC 2008

Hello all,

  I've been a mythtv user for a few years.  My configuration is a single
system frontend/backend.  Since it's inception I have been using realtime
commercial flagging and it has worked very well.  However, I recently
updated my mythtv svn tree (to 17392 from an update 5/3/08) and every once
in a while the system completely hangs.  It hangs to the point where the
magic Alt-SysRq-REISUB does not reboot it, no SSH, no three-fingered-salute,
no nothing.

  I get nothing in my logs (FE, BE, syslog, messages, etc) and it appears to
happen when recording and doing commercial detection.  It froze three times
over three days and I started to worry.  I completely disabled commercial
detection and it worked for two days straight so I decided to turn
comflagging back on because the queue was huge.  It detected all the
commercials in the recorded shows and the next day while recording and
comflagging it died again!  So I turned off the realtime comflag option and
it has been working for two days now without a hang.

  I thought maybe it was a memory issue so I sacrificed a few shows and ran
memtest86 overnight; it completed 12 cycles and didn't report any errors.
None of the information I have proves anything but so far it's looking like
some update done in may to the comflagger is the culprit.  Anyone have
information that supports or debunks this theory?  It's not a big loss to
not have realtime comflagging but it was a cool geek thing to tout. :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080603/fa349b0c/attachment.htm 

More information about the mythtv-users mailing list