[mythtv-users] lirc problems. can't transmit to set top box

Mache Creeger mache at creeger.com
Tue Jun 3 01:32:19 UTC 2008

Do you have a /home/mythtv/.myth/lircrc, /home/mythtv/.lrcrc, and 

-- Mache

At 05:29 PM 6/2/2008, Say It wrote:
>Hi, I have built a mythtv box, but cannot get the IR
>transmitter to work.
>Knoppmtyh Release 5 F27
>TV Card : Hauppauge Wintv Go Plus w/ remote
>Video Card: Nvidea
>The Myth TV part seems to be working fine.  I can
>record and playback shows fine.  I can even get the
>Hauppauge remote to work fine to change menus on
>mythtv.  The irw commands work fine. However, I cannot
>get the IR transmitter to change the channels on the
>cable set top box.
> From what i understand, I do not have a serial
>transmitter.  Most of the docs i see out there mention
>serial IR transmitter and requiring two lirc
>instances.  Mine is part of the cable that comes out
>of the IR port
>on the Hauppauge card.  Basically, the IR port on the
>card has a cable plugged into it that splits out to an
>IR receiver and an IR transmitter.  The IR receiver
>works fine.  I cannot get the IR transmitter to work.
>When I do a: irsend SEND_ONCE DCT700 info
>I get this error:
>irsend: command failed: SEND_ONCE DCT700 info
>irsend: hardware does not support sending
>When I run:
>irsend LIST DCT700 ""
>That gives back a response.  I'm thinking this command
>only looks at the /etc/lircd.conf command and not
>actually send anything to the IR transmitter.
>Syslog says:
>Jun  2 15:36:42 mythtv lircd-0.8.3[2678]: accepted new
>client on /dev/lircd
>Jun  2 15:36:42 mythtv lircd-0.8.3[2678]: error
>processing command: SEND_ONCE DCT700 info
>Jun  2 15:36:42 mythtv lircd-0.8.3[2678]: hardware
>does not support sending
>Jun  2 15:36:42 mythtv lircd-0.8.3[2678]: removed
>I tried this with lircd-0.8.2 and still had the same
>problems, so I decided to get the newest lirc and
>compile it myself.  I compiled lirc 0.8.3 with:
>/configure --with-syslog --with-transmitter
>/configure --with-kerneldir=/usr/src/linux
>--with-syslog --with-transmitter
>I got some errors when doing the make and make
>install, something about not able to find crtbeginS.o
>It seemed to install okay since the logs are showing
>the newer version of lirc.  I'm not that familiar w/
>compiling programs.  Is there a way to check if I've
>setup lirc okay?
>I have several entries in /etc/lircd.conf
>DCT700 is the cable box set top box model.  I've put
>those codes in /etc/lircd.conf.
>lircd.conf also has entries for: blaster, Hauppauge,
>hauppauge_pvr, Hauppauge_350
> From my understanding, the lircd.conf should have
>entries for the cable tv stb (IR transmit) and the
>remote control unit (IR receiver).
>It seems that I can specify anything (e.g., DCT700,
>junk, blah, etc.) in the IRSEND command and get the
>same error message.
>Some other specs:
>crw-rw-r-- 1 root video 61, 0 Jun  2 02:25 /dev/lirc0
>srw-rw-rw- 1 root root      0 Jun  2 02:25 /dev/lircd
>dmesg | grep lirc
>lirc_dev: IR Remote Control driver registered, major
>lirc_i2c: chip 0x10005 found @ 0x71 (Hauppauge PVR150)
>  ---> Not sure why it says PVR150.
>lirc_dev: lirc_register_plugin: sample_rate: 10
>root at mythtv:/usr/src/mylirc/lirc-0.8.3# lsmod | grep
>lirc_i2c               12420  2
>lirc_dev               16644  1 lirc_i2c
>i2c_core               20864  20
># /etc/lirc/hardware.conf
>MODULES="lirc_dev lirc_i2c"
>root at mythtv:/usr/local/sbin/lircd --driver=?
>Driver `?' not supported.
>Supported drivers:
>         default
>/sbin/modprobe lirc_i2c
>/usr/local/sbin/lircd --device=/dev/lirc0
>Any help would be appreciated.  I'm trying to give
>this to my dad for father's day.  It was originally
>supposed to be an xmas gift, but I've had so many
>problems getting this to work.
>mythtv-users mailing list
>mythtv-users at mythtv.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080602/b2e3479d/attachment.htm 

More information about the mythtv-users mailing list