[mythtv-users] stuttering problem (doubling video frame interval to slow down)

Bryan Murphy bmurphy1976 at gmail.com
Thu Jul 31 13:46:00 UTC 2008

On Thu, Jul 31, 2008 at 2:17 AM, Mark Kendall <mark.kendall at gmail.com>wrote:

> Not sure if it's the problem, but do you have any idea why the
> timestretch is set to 0.45?


For the source you're playing, frame interval should match the refresh rate.
> Regards
> Mark

That's a good question.  As I had not noticed this previously in the logs, I
ran another test this morning just to be 100% certain that I had not grabbed
the log while I was playing around with the time stretch settings.  I
confirmed that this message is repeated:

2008-07-31 08:40:54.184 NVP: ClearAfterSeek(0)
2008-07-31 08:40:54.186 NVP: Changing speed to 0.45
2008-07-31 08:40:54.186
RingBuf(/mnt/mythtv/tv/1111_20080730040000.mpg): CalcReadAheadThresh(0
-> threshhold(64 KB) min read(0 KB) blk size(32 KB)
2008-07-31 08:40:54.187 NVP: DoPlay: rate: 59.9401 speed: 0.45 skip: 1
=> new interval 37074

2008-07-31 08:40:54.187 NVP: Stretch Factor 0.45, disable passthru

I made no changes to the playback settings (or timestretch), I simply
restarted mythfrontend and immediately played the video.

Is this the problem?  Why would the stretch factor be getting set to this

I grabbed a log of the MythTV output playing a video that does not exhibit
this problem and you can view it by clicking the link below.  After looking
through the log, I do not see the stretch factor/changing speed messages.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080731/99c39af4/attachment.htm 

More information about the mythtv-users mailing list