[mythtv-users] Help installing HDHomerun - HDHR Error - Network is unreachable after reboot

Roger Heflin rogerheflin at gmail.com
Thu Jul 10 19:28:22 UTC 2008

Alen Edwards wrote:
> Thanks for the reply. That is basically what I have been doing, I think 
> 5 or 6 times now.
> Just to make sure, I just tried it again.  This time I was able to 
> install all 4 tuners (HDHR + 2 air2pc)and everything worked fine until I 
> rebooted the computer.  Now, both HDHR tuners show Not Available.
> I looked at the mythbackend.log and found this:
> HDHRChan(10137dc1/0), Error: Unable to send discovery request
>                          eno: Network is unreachable (101)
> I have one of these error messages for each tuner.
> I issued a command:
> $ hdhomerun_config discover
> hdhomerun device 10137DC1 found at
> So, it is there and reachable and I can ping it, which makes since as I 
> was using it before the reboot.
> These error messages do not show up in a google search.
> Both the computer and the HDHR are connected to a switch that is 
> connected to my network and DHCP router which is upstairs.
> AMD 5400+ CPU on ASUS M3A MB
> Anyone?

If I was guessing I would suspect that the network was not fully up when it 
looks for the HDHR.

What runlevel is dhcp, and what runlevel does mythtv startup as, and is the 
network fully up when mythtv tries to start?  You may want to put some simple 
debugging code in the mythtv startup script to save the network status at the 
time the script runs (something like "ifconfig -a > /tmp/somefile"

And even if the runlevel for dhcp is before mythtv, it still may not be fully 
configured by the time mythtv tries to start, if the mythtv runlevel is higher, 
and the network is still not quite there yet, you may have to put something in 
mythtv to delay the startup a set amount, or delay until you have an ip address 
(and fall out after a fixed amount of time that would indicate other issues).


More information about the mythtv-users mailing list