[mythtv-users] DVI Output During Boot

dvjunk at netscape.net dvjunk at netscape.net
Thu Jan 31 00:00:17 UTC 2008


Attached Message




David Greaves <myth at dgreaves.com>




Discussion about mythtv <mythtv-users at mythtv.org>




Re: [mythtv-users] DVI Output During Boot




Wed, 30 Jan 2008 11:33:01 +0000



>Ginsu Squirrel wrote:

>> I have my myth box connected to my TV with a DVI to HDMI cable.  I get 

>> no output on the TV until the X server has started (no post, no grub, no 

>> kernel messages).  I have 3 nvidia cards and one ati card.  One nvidia 

>> card, an 8400GS PCI-Express, doesn't have this problem but the other 

>> cards, an nvidia 5200, an nvidia 5500, and an ATI 9600 do.  Has anyone 

>> seen this and is there a way to get output during boot?


>I have seen something similar...


>I wonder if your card is sending a signal that the TV can't display (80x25 



>If you have a DVI monitor you can see if the card is actually displaying during

>POST (I'm sure it is).


>If you switch to VT 1 (ctrl-alt-F1) does that display?


>If not then you may want to use the framebuffer console (fbcons) and switch

>resolution. My VT's now run at 1920x1280 :)


>You will need to alter grub to supply a vga= parameter. It still won't display

>POST but you'll see the boot sooner.


>(Nb fbcons also lets you run 'splashy' so you can have a pretty bootup sequence

>- good for a TV PC.)




Along this line, last night I took my system and tried connecting it to my 

37"LCD (Vizio VX37L). I have been testing on a 17" CRT.

I was able to see boot text (bios, grub etc.), however when it got to 

starting Mythfrontend (I think) the screen went blank then it came back 

with the login screen after a few seconds. Every time I tried rebooting/ 

restarting it crashed approx when I think Mythfrontend was starting.

I found this in mythfrontend log(not exact - writing this up from work):

...... Switching to square mode ...

>mythfrontend: Fatal IO error: client killed 

I had to boot into a failsafe terminal and re-install the NVIDIA drivers 

(latest version - don't remember the number) to get things working again.

Why would plugging in a DVI to HDMI cable cause such a crash. I must 

have something set up wrong, which I should fix before trying it again.

I have an ASUS NVIDIA 6200 video card, using latest custom 

kernel (with the patch for my Kworld 110 remote), mythbuntu.

Any thoughts on why this would happen?




mythtv-users mailing list

mythtv-users at mythtv.org



More new features than ever.  Check out the new AIM(R) Mail!


More new features than ever.  Check out the new AIM(R) Mail ! - http://webmail.aim.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080130/c0d05bc7/attachment.htm 

More information about the mythtv-users mailing list