[mythtv-users] database problem

steve sfreilly at roadrunner.com
Fri Jan 25 03:08:50 UTC 2008

Hash: SHA1

Michael T. Dean wrote:
| On 01/24/2008 09:21 PM, Dean Harding wrote:
|> steve wrote:
|>> any advice would be appreciated.  thanks.
|> I would try executing "CHECK TABLE settings" in mysql and if there are
|> any errors, "REPAIR TABLE settings" (might be a good idea to run
|> optimize_mythdb.pl if the settings table is corrupted).
| I recommend just using optimize_mythdb.pl, instead.

ok, ran the optimize script, and got this.

steve at steve-desktop:/usr/share/doc/mythtv-backend/contrib$ sudo
/etc/init.d/mysql restart
~ * Stopping MySQL database server mysqld
~ [ OK ]
~ * Starting MySQL database server mysqld
~ [ OK ]
~ * Checking for corrupt, not cleanly closed and upgrade needing tables.
steve at steve-desktop:/usr/share/doc/mythtv-backend/contrib$ sudo sh
optimize_mythdb.pl: 14: use: not found
optimize_mythdb.pl: 17: Syntax error: word unexpected (expecting ")")
steve at steve-desktop:/usr/share/doc/mythtv-backend/contrib$

im going to assume theres something wrong with that script,

so then I tried an "optimize table" for everything through phpmyadmin,
and got no errors, but still get the same error when trying to start myth.

steve at steve-desktop:/$ mythbackend -d
steve at steve-desktop:/$ 2008-01-24 22:06:11.882 Using runtime prefix = /usr
2008-01-24 22:06:11.895 New DB connection, total: 1
2008-01-24 22:06:32.108 Connected to database 'mythconverg' at host:
2008-01-24 22:06:32.112 Current Schema Version:
2008-01-24 22:06:32.115 New DB connection, total: 2
2008-01-24 22:06:32.116 Connected to database 'mythconverg' at host:
2008-01-24 22:06:32.118 Newest Schema Version : 1160
2008-01-24 22:06:32.119 New DB connection, total: 3
2008-01-24 22:06:32.120 Connected to database 'mythconverg' at host:
2008-01-24 22:06:32.121 Setting Lock for Database Schema upgrade. If you
see a long pause here it means the Schema is already locked and is being
upgraded by another Myth process.
2008-01-24 22:06:32.122 New DB connection, total: 4
2008-01-24 22:06:32.123 Connected to database 'mythconverg' at host:
2008-01-24 22:06:32.125 Told to create a NEW database schema, but the
already has 80 tables.
If you are sure this is a good mythtv database, verify
that the settings table has the DBSchemaVer variable.

2008-01-24 22:06:32.126 Database Schema upgrade FAILED, unlocking.
2008-01-24 22:06:32.126 Couldn't upgrade database to new schema

im probably just going to have to dump the database right?

Steve Reilly


Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the mythtv-users mailing list