[mythtv-users] Where the bottleneck?

Kevin Kuphal kkuphal at gmail.com
Wed Jan 23 17:42:20 UTC 2008

On Jan 23, 2008 10:30 AM, Mitch Gore <mitchell.gore at gmail.com> wrote:

> Hi,
> I having issues with HD video stuttering when a recording stops and begins
> commflaging.  After the commflag gets started it plays fine but there is a
> 45sec period where video is unwatchable.  So where is the bottleneck?
> Here is my system:
> Fedora 8 64bit/fully updated
> MythTV atrpms-bleeding packages
> AMD X2 5200 (2.4Ghz)
> 1 gb of DDR2 800
> 500gb sata drive (w/10gb system partition and the rest recordings)
> 120gb sata (w/2.5GB SWAP and the rest recordings)
> HDHomeRun
> using onboard nVidia 6150 w/128mb Ram allocated.
> Dual head display, one 1080p projector for the frontend and one 15"LCD for
> admin work.
> When all this is happening my Ram is used 73% and 25% is cache.  I use
> about 350mb of SWAP.  Also when looking at HTOP the processor is not maxed
> out so I don't believe that is the issue.
> Would a new system only drive help?  More Memory?  PCI-X video card?
Probably the disk. Most likely the fact that you are sharing system,
database, logs, and recordings on the 500GB SATA drive is causing issues.
I've moved to recommending a separate drive at the *minimum* for your
database and logs (usually /var).  Obviously this can exist with the system
if needed but should not be shared with recordings.  I found once I did this
that performance increased dramatically since all the I/O contention between
recording (seektables to the DB) and commflagging (reading seektables from
DB) and watching (again, reading seektables from DB) combined with the
actual video files themselves was separated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080123/9bd0735a/attachment.htm 

More information about the mythtv-users mailing list