[mythtv-users] Upgraded to SVN - Firewire works but still can't change channels

Matt Emmott memmott at gmail.com
Tue Jan 22 21:59:36 UTC 2008

Thanks to the multiple discussions on this list I decided to give SVN a try.
I used the excellent tutorial at
http://www.mythtv.org/wiki/index.php/Installing_MythTV_SVN_on_Fedora_Core to
reload my Fedora Core 6 box, and am now running a recent build of SVN - I
believe it's about a week old.

I'm still having issues with my HDHomeRun but that's not important right now
- What's important is that I can reliably watch SD and HDTV over firewire to
my SA3250 box! Hooray! However I'm having the same problem I had previous to
my upgrade - my external channel change script doesn't work in Myth. I'll
watch tv via firewire and when I tell Myth to change the channel, I get a
black screen for a second and am then returned back to the channel I was
originally on, even though Myth now tells me I'm on the 'new' channel. There
are no errors in the logs, everything looks like it worked (other than the
fact that I never changed the channel). I can alt-tab to my shell and run
sa3250first 005 as mythtv, and the cable box will change to channel 5. It
just doesn't work in Myth.

More info on the particular script. I compiled the latest sa3250ch
executable in the contrib directory and dropped it into /usr/local/bin, but
that script still doesn't work reliably. I have to use a script that I named
sa3250first, obtained through this mailing list, which calls sa3250ch
correctly. The script is as follows:


l=`echo $1 | awk '{print length($0)}'`

if [ $l -eq 3 ]
 sa3250ch -s $1

if [ $l -eq 2 ]
 sa3250ch -s 0
 sa3250ch -s $1

if [ $l -eq 1 ]
 sa3250ch -s 0
 sa3250ch -s 0
 sa3250ch -s $1

I've explicitly stated the path in mythtv-setup as /usr/local/bin/sa3250ch
with no luck. I've seen some mention of appending a -s at the end of the
command which does not work either - I couldn't find any mention of the -s
switch, what's it for? Both files are owned by the myth user and are

-rwxrwxrwx 1 mythtv mythtv 8694 Jan 21 18:29 sa3250ch
-rwxrwxrwx 1 mythtv mythtv  218 Dec 13 19:23 sa3250first

Anything else I can try? I'm so close to actually working - I recorded the
new Terminator show in HD over firewire last night and reliably streamed it
using Mythweb to my laptop on an 11g network! Living the dream! - Now I just
need to change the channels!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080122/7b5cae0a/attachment.htm 

More information about the mythtv-users mailing list