[mythtv-users] Suddenly Unable to watch LiveTV?

Rich West Rich.West at wesmo.com
Mon Jan 21 16:47:22 UTC 2008

Since I hadn't heard any suggestions, and the only hint I had was one 
posting on a web site suggesting that the poster solved a similar 
problem by speeding up the channel change script that they had 
(completely different than what I have), I thought I would dig in to 
that further.

It does look to be the case here that MythTV is timing out on LiveTV 
because the channel change script is taking too long, as evident by the 
numerous "ret_pid(0) child(9812) status(0x0)" lines.  I "strace"d the 
directv.pl script, and saw that it was hanging for several seconds just 
opening up the USB serial port.  Out of frustration, I rebooted the 
backend, and channel changing and live tv started working again.

This seems kind of a harsh solution, so I am going to dig a little 
further to see if I can just reload the usbserial and pl2303 kernel 
modules to return things back to normal functionality.  Unfortunately, 
right now, since I rebooted the machine, I don't have the error 
condition to work with, so my testing will have to wait until the 
problem comes back. :(


Rich West wrote:
> I searched around on Google and on the mailing list archives, but I 
> wasn't able to come up with a viable answer. :(
> I've had MythTV up for a little over a year now, and, although there 
> have been some bumps in the road, it's been running as a great solution 
> for us.  Recently, though, I was told of some problems when attempting 
> to "Watch TV".  Specifically, my in-laws were over, and it took them a 
> couple of times to get it to display video.  I didn't think much of it 
> since it eventually worked and since we never really use "Watch TV" 
> anyhow.. :)
> However, I discovered today when my in-laws were over that we couldn't 
> "Watch TV" at all.  It would pause with a blank screen for about 3 to 5 
> seconds or so, then come back to the main menu screen.  Recordings work, 
> and if I go to the program guide and record a current running show, it 
> will record and it can be watched.  I tried it with and without "Avoid 
> conflicts with LiveTV" to no avail.
> The mythtv logs show:
> 2008-01-20 23:59:59.022 MainServer::HandleAnnounce Playback
> 2008-01-20 23:59:59.025 adding: mythtv4 as a client (events: 0)
> 2008-01-20 23:59:59.028 TVRec(5): Changing from None to WatchingLiveTV
> 2008-01-20 23:59:59.031 TVRec(5): HW Tuner: 5->5
> 2008-01-21 00:00:00.097 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:01.102 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:02.111 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:03.115 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:04.118 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:05.123 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:06.126 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:07.129 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:08.132 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:09.134 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:10.136 ret_pid(0) child(9812) status(0x0)
> 2008-01-21 00:00:11.139 ret_pid(9812) child(9812) status(0x0)
> 2008-01-21 00:00:11.140 External Tuning program exited with no error
> 2008-01-21 00:00:11.279 MPEGRec(/dev/video2) Error: Error getting codec 
> params using old IVTV ioctl
>                         eno: Bad address (14)
> 2008-01-21 00:00:11.301 TVRec(5): Changing from WatchingLiveTV to None
> 2008-01-21 00:00:11.720 Finished recording The Good Night Show "Shapes": 
> channel 1295
> 2008-01-21 00:00:11.734 MythSocket(1394b00:-1): writeStringList: Error, 
> socket went unconnected.
> I've seen some references to the possibility that the channel changing 
> script might be just too slow (using directv.pl), but I don't quite know 
> how to speed that one up.  In fact, it seems slower than I remember.  I 
> did some quick timings, and it is taking ~10 seconds for the 
> change_channel script to exit.  Could this be the source of the 
> problem?  Is there a way to tell mythtv to wait, say, 15 seconds, before 
> giving up?  Is this a case where mythtv *is* giving up, or am I barking 
> up the wrong tree?
> -Rich

More information about the mythtv-users mailing list