[mythtv-users] MythTV start up problems (permissions)

Piers Kittel mailing at biased.org
Mon Jan 21 14:22:19 UTC 2008


Thanks again for your time!

> If you see the pid file do this
> /etc/init.d/mythtv-backend zap
> Not sure if zap is a proper option in debian but in gentoo this  
> kills the
> pid file, which is what tells the script that the process is still  
> running.
> One more thing, if you have a .mythtv folder in /var/run/mythtv  
> check it for
> a mysql.txt file. Open said file and make sure the user/pass for  
> your mysql
> connection are correct.

The mythtv-backend script doesn't have the zap parameter, but anyway,  
if I do an /etc/init.d/mythtv-backend stop it deletes the PID file  
anyway, but despite that, it still doesn't start up.

> The dirty fix for this error is to change the location of where the  
> pid file
> is saved.
> You can do this by editing your startup script and changing the  
> RUNDIR= line
> to a new location. This will allow you to create a mysql.txt file in  
> the new
> location inside the .mythtv folder of the new location that will  
> delete the
> file every time you startup the system. Negatives to this? None but  
> the fact
> that the pid file is not in the /var/run folder like the rest of them.
> My location is /etc/conf.d/mythtv. You may need to create the folder  
> before
> putting it in the RUNDIR line.

Put the mysql.txt in /etc/conf.d/mythtv/.mythtv and set RUNDIR= to  
RUNDIR=/etc/conf.d/mythtv - the PID file gets created in that folder  
fine.  Still doesn't work, but looking in the logs, the problem has  
been fixed, but there is a different issue now:

2008-01-21 14:18:12.899 Using runtime prefix = /usr
2008-01-21 14:18:13.006 New DB connection, total: 1
2008-01-21 14:18:13.026 Connected to database 'mythconverg' at host:  
2008-01-21 14:18:13.040 Current Schema Version: 1160
Starting up as the master server.
2008-01-21 14:18:13.059 New DB connection, total: 2
2008-01-21 14:18:13.061 Connected to database 'mythconverg' at host:  
2008-01-21 14:18:13.065 mythbackend: MythBackend started as master  
2008-01-21 14:18:13.076 New DB connection, total: 3
2008-01-21 14:18:13.079 Connected to database 'mythconverg' at host:  
2008-01-21 14:18:13.104 EITHelper: localtime offset 0:00:00
2008-01-21 14:18:13.217 EITHelper: localtime offset 0:00:00
2008-01-21 14:18:13.309 New DB scheduler connection
2008-01-21 14:18:13.311 Connected to database 'mythconverg' at host:  
2008-01-21 14:18:14.718 Main::Registering HttpStatus Extension
2008-01-21 14:18:14.721 mythbackend version: 0.20.20070821-1 www.mythtv.org
2008-01-21 14:18:14.722 Enabled verbose msgs:  important general
/video/nfslockfile.lock: Permission denied
Unable to open lockfile!
Be sure that '/video' exists and that both
the directory and that file are writeable by this user.

I note that the /video folder and everything in that folder is owned  
by the user root - is it save to change owner and group of the folder  
and contents to mythtv?

Thanks very much for your time again!

Regards - Piers

More information about the mythtv-users mailing list