[mythtv-users] Intel and XvMC

R. G. Newbury newbury at mandamus.org
Mon Jan 21 00:57:37 UTC 2008

David Whyte wrote:
> On Jan 18, 2008 3:49 AM, Edward Hughes IV <echughesiv at gmail.com> wrote:
>> You could try adding the line:
>>      Option     "XvMCSurfaces" "7"
>> to your device section to see if XvMC is supported for your chipset.  I
>> doubt it is, as the man page still states that it only works for the i810
>> and i815 chipsets.  By checking your Xorg log, you'll be able to see.  You
>> can run:
>>      cat /var/log/Xorg.0.log | grep XvMC
>> It will either return a statement that it was enabled, or that the
>> "XvMCSurfaces" option is not used, which means that the driver doesn't
>> support your chipset.
> Bugger, you're right, it isn't supported yet for me.
> djwhyte at myth:~$ cat /var/log/Xorg.0.log | grep XvMC
> (WW) intel(0): Option "XvMCSurfaces" is not used
> djwhyte at myth:~$
>> For more information on the driver, check the manpage
>> with:
>>      man intel
>> Anyway, it sounds like if we are just patient, accelerated video decoding
>> for Intel adapters is on the way!
> *drums fingers* I am waiting :P  Hopefully, it won't be too far away.

A little bit of thread stleainng here, but the question is about intel 
ans xvmc.

I am trying to build the xvmc branch of the intel driver togther with X 
version 1.4..However, the xserver build fails down in /GL/glx on 
glxdri.c  because it cannot find a number of include files...more 
specifically glapitable.h and glapi.h

These files are not on my system and I have very carefully gone through 
and installed/updated all X requirements according to the xor wiki 
modular developers guide.

Anyone got a clue?


More information about the mythtv-users mailing list