[mythtv-users] Myth can't passthrough digital audio, but xine and mplayer can

Marc drayson at net1plus.com
Sat Jan 19 18:29:53 UTC 2008

> -----Original Message-----
> From: mythtv-users-bounces at mythtv.org [mailto:mythtv-users-
> bounces at mythtv.org] On Behalf Of Michael T. Dean
> Sent: Saturday, January 19, 2008 1:01 PM
> To: Discussion about mythtv
> Subject: Re: [mythtv-users] Myth can't passthrough digital audio, but
> xine and mplayer can
> On 01/18/2008 09:28 PM, Ray Lischner wrote:
> > I've tried /dev/dsp and /dev/adsp as the audio device. I've tried
> > Default and the other built-in choice for the pass-through device, as
> > well as ALSA:hw=0,1 (because the digital device is 1 on card 0).
> >
> > The result is consistent. With pass through enabled, the receiver
> picks
> > up the digital encoding, but no sound.
> >
> > With xine,
> which has a whole different mechanism for configuration
> >  I don't need to mess with anything. I just select Pass
> > through for the audio, and it just works. So I'm still trying to
> figure
> > out what's different.
> $ cat ~/.xine/config | grep passthrough
> #audio.device.alsa_passthrough_device:iec958:AES0=0x6,AES1=0x82,AES2=0x
> 0,AES3=0x2
> Hmmm.  xine has a default value for the passthrough device.  It's not
> one of the values you've tried (though you need to fix the format for
> the one Myth uses)...
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Post the output for the following command.
aplay -l

You should be able to then implement a ~/.asoundrc or /etc/asound.conf
configuration file like the one found at
http://www.mythtv.org/wiki/index.php/Configuring_Digital_Sound to set your
audio for digital passthrough.

For example I am using the config file there.
My aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 -
  Subdevices: 1/1
  Subdevice #0: subdevice #0

>From this we determine that my IEC958 (passthrough) is device 4.
My modifications to the config are as follows

pcm.!default {
  type plug
## Uncomment the following to use "mixed-analog" by default
#  slave.pcm "dmix-analog"
## Uncomment the following to use (unmixed) "digital" by default
#  slave.pcm "digital-hw"
## Uncomment the following to use "mixed-digital" by default
  slave.pcm "dmix-digital"
To give configure audio as digital audio.

# Alias for digital (S/PDIF) output on the card
# Do not use this directly--it requires specific rate, channels, and format
pcm.digital-hw {
  type hw
  card 0
#  device 1
#  - Comment out "device 1" above and uncomment one of the below or create a
#    new "device N" line as appropriate for your sound card or
#  device 2
  device 4
To configure s/pdif on card 0 device 4 as identified by aplay -l

The other issue could be that you have the correct passthrough device
configured in mythfrontend setup but do not have passthrough enabled. Or you
have it enabled but you do not have the correct passthrough device selected.
My output device is set for "ALSA:default"
My passthrough is set for "ALSA:iec958:{ AES0 0x02 }"
My mixer device is set for "default" (note this is different from
ALSA:default. This is the default as defined in the ~/.asoundrc or
/etc/asound.conf configuration file)

More information about the mythtv-users mailing list