[mythtv-users] * Please help -- can't schedule recordings (but can record with R, can view guide)

R. G. Newbury newbury at mandamus.org
Fri Jan 18 04:57:04 UTC 2008

dataclue wrote:
> I got a couple of replies to this, thank you for those
> that kindly tried to help -- but it is still unsolved.
> In my earlier problem with MythTV, I got *NO* replies.
> Is there some rules for this list that I'm violating?
> Is this the right list? 
> --- dataclue <dataclue at yahoo.com> wrote:
>> Date: Sun, 13 Jan 2008 18:17:29 -0800 (PST)
>> From: dataclue <dataclue at yahoo.com>
>> Subject: Please help -- can't schedule recordings
>> (but can record with R, can view guide)
>> To: mythtv-users at mythtv.org
>> CC: dataclue at yahoo.com
>> Please help. Cannot get anything scheduled from the
>> program guide although recording the current program
>> works from within live TV and shows correct program
>> information. There are no error messages displayed
>> but
>> it always says "not recording" and "preview of
>> schedule changes" alawys says: "no changes will be
>> made". Also, it appears that schedulign the show
>> does
>> something -- I can run "mythbackend --testsched" and
>> get output of my attempted schedules. But
>> "mythbackend
>> -- printsched" doesn't do anything. 
>> All of this is regardless of any settings. I'm using
>> ScheduleDirect and the latest version of MythTV. 
>> Please help. It has taken a very long time to get
>> MythTV working even though I tend to think of myself
>> as having reasonable skills. 
>> (By the way, my earlier problem with sound recording
>> being broken by upgrading MythTV, to which no one
>> responded, was eventually resolved by upgrading ALSA
>> and the kernel. It also seems essential to regular
>> restart the computer. Direct digital input has never
>> worked, but the CD input is working again). 

The prime reason for the lack of response is that your problem is not 
well defined, so it is hard to deduce what *could* be wrong.

Did you follow the Myth documentation for setup?

Do this test, to start: cd to your database (var/lib/mysql in Fedora) 
and run du -h. Nake note of the size of the mythconverg databsae. Not a 
bad moment, either to do a backup using mysqldump.

When you run mythfilldatabase in a console do you see it report the 
correct number of channels being updated as you have in your 
SchedulesDirect setup?

Re-run the 'du -h' test. Does it report a change in the size? It may not 
change a lot due to deletions, but it should change by some amount. IF 
not, then mythfilldatabase is failing to update properly. Been 
there...turned out to be a permissions problem on /tmp where 
mythfilldatabase stores its temp files.

If all that looks good, then its likely a database problem.
Do you have ONLY ONE my.cnf file (in /etc), and ONLY ONE mysql.txt file 
(in ~/.mythtv). Remove any others, or make sure that there is only one 
version by using symlinks.

You ARE saving the recording schedule record and not just escaping from 
the screen by mistake?

Try going into 'Schedule Programs' -> Program Guide and select some 
programs which are about to start. You want to select three programs if 
you have 2 tuners, four if you have 3 etc. Select and save. It should 
refuse to allow you to save the 'extra' show...If you go back to the 
guide, that show will have a marker in the bottom right corner, but will 
not  be coloured in. If you then go to 'Upcoming Recordings' it will 
show 'Conflict' and the date at the top right, and should show the 3 (or 
whatever) programs you have attempted to schedule.

I can't help any more than that. Either its the nut holding the keyboard 
which has failed, or something is seriously wrong with your setup and a 
re-install and very careful stepthrough of (for example( Jarod Wilson's 
guide is indicated.


More information about the mythtv-users mailing list