[mythtv-users] Setting up mythtv on debian etch

Jorge Luis jorgeperez326 at optonline.net
Thu Jan 17 23:34:29 UTC 2008

I ran dpkg-reconfigure mythtv-database

Then I try to run mythbackend and this is the output
Session management error: Authentication Rejected, reason : None of the 
authenti cation protocols specified are supported and host-based 
authentication failed
2008-01-17 18:31:07.480 Using runtime prefix = /usr
2008-01-17 18:31:07.535 New DB connection, total: 1
2008-01-17 18:31:07.543 Connected to database 'mysql' at host: home1
2008-01-17 18:31:07.561 Current Schema Version:
2008-01-17 18:31:07.563 DataDirectProcessor::FixProgramIDs() -- begin
2008-01-17 18:31:07.564 New DB DataDirect connection
2008-01-17 18:31:07.565 Connected to database 'mysql' at host: home1
2008-01-17 18:31:07.566 DB Error (Fixing program ids in recorded):
Query was:
UPDATE recorded SET programid=CONCAT(SUBSTRING(programid, 1, 2),       
'00', SUBSTRING(programid, 3)) WHERE length(programid) = 12
Driver error was [2/1146]:
QMYSQL3: Unable to execute query
Database error was:
Table 'mysql.recorded' doesn't exist

2008-01-17 18:31:07.568 New DB connection, total: 2
2008-01-17 18:31:07.569 Connected to database 'mysql' at host: home1
2008-01-17 18:31:07.570 Newest Schema Version : 1160
2008-01-17 18:31:07.572 New DB connection, total: 3
2008-01-17 18:31:07.576 Connected to database 'mysql' at host: home1
2008-01-17 18:31:07.576 Setting Lock for Database Schema upgrade. If you 
see a l ong pause here it means the Schema is already locked and is 
being upgraded by an other Myth process.
2008-01-17 18:31:07.578 New DB connection, total: 4
2008-01-17 18:31:07.579 Connected to database 'mysql' at host: home1
2008-01-17 18:31:07.581 Told to create a NEW database schema, but the 
already has 17 tables.
If you are sure this is a good mythtv database, verify
that the settings table has the DBSchemaVer variable.

2008-01-17 18:31:07.581 Database Schema upgrade FAILED, unlocking.
2008-01-17 18:31:07.582 Couldn't upgrade database to new schema

George Nassas wrote:
> On 17-Jan-08, at 5:54 PM, Jorge Luis wrote:
>> I run mythtv setup but I think is not saving any of my setup in the
>> respective databases.  The message in  xshell tells me something like
>> "mysql.videosource table doesn't exist".  I figure I don't have the
>> mysql database setup correct or created.  I do not know how to  
>> create them.
> It should be looking for videosource in the mythconverg database  
> which means you don't have mythtv-database installed or it didn't  
> configure correctly. I'm not near my machine but, assuming mythtv- 
> database is installed, something like dpkg-reconfigure mythtv- 
> database ought to help.
> In general if you "apt-get install mythtv" it should do all the right  
> things to put the binaries in place & create the DB & a mythtv user  
> with correct permissions and so on.
> - George
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list