[mythtv-users] NFS problems

Larry Sanderson larry.sanderson at gmail.com
Wed Jan 16 20:22:56 UTC 2008

On Wednesday 16 January 2008 03:12:38 pm Brent Norris wrote:
> As of yesterday I started having NFS problems with my machines.  It
> started when I rebooted one of my frontends and it wouldn't reconnect
> to the NFS shares on my backend.  This this morning after a power
> outage my other frontend had similar issues.
> So I went to my backend and attempted to mount a share from it to it.
> That failed several times and then without me really doing anything
> it started succeeding.  Going back to my frontend sadly it didn't
> just magically start working either.
> Looking in /var/log/messages I can see the frontend connect because
> it logs an entry:
> mountd[4193]: authenticated mount request from
> for /home/mythtv (/home/mythtv)
> but on the frontend it just says that it timed out.  I am not even
> sure where to look to troubleshoot this as NFS has never really been
> my strong suite.  Can anyone offer a little advice on what to look
> for or look at?

This probably won't help, but I encountered a similar situation 
recently.  The way I eventually fixed it was to clear all my exports 
and recreate them (exportfs -u -a && exportfs -a)

I have no idea why this worked when a reboot didn't, but there it is.  
This happened on Saturday, and it's been working fine since.

More information about the mythtv-users mailing list