[mythtv-users] Help me disable screen blanking in FC7

Larry K lunchtimelarry at gmail.com
Tue Jan 15 14:50:24 UTC 2008

On Oct 18, 2007 2:38 PM, Jonathan Rogers <jonner at teegra.net> wrote:

> Hash: SHA1
> Jason McMillon wrote:
> > /usr/bin/xset -display :0.0 s off
> > /usr/bin/xset -display :0.0 -dpms
> >
> > Again, to reiterate in case anyone searches the list with a similar
> problem...
> >
> > I installed a tftp server that required xinetd which apparently
> > overwrote kde's screen saver settings require me to run the above
> > commands after every reboot.  I couldn't find any other commands that
> > would work.  The -display:0.0 is required since xset should be run
> > within x-windows (I think).
> That would be very strange if xinetd did anything to any screen saver
> settings, since it's a network server only and unrelated to Xorg. A
> while ago, I had the same problem that you had. I had used 'Option
> "BlankTime" "0"' in the ServerLayout section of xorg.conf. Then, after
> upgrading Xorg, the screen started blanking, so apparently Xorg had a
> regression that caused it to ignore the blanking option. I managed to
> fix it by running "xset s off" in my mythfrontend session startup
> script. The xset command is a regular X11 client, so running it at the
> beginning of the X session is appropriate. As you discovered, you can
> run it from cron with "-display :0.0" as long as that's the correct
> display, but that's ugly.
> I'm not sure if you encountered the same bug, but there are few things
> as frustrating as software that silently ignores documented configuration.
> Jonathan Rogers
As crazy as it sounds, I think there may be a connection between the
networking stuff and the problems with the screen going blank.  At least, on
FC7, it appears so.

This past summer, I was forced to rebuild my older machine to overcome the
zap2It problem.  I built an FC7 box, and everything worked mostly correct,
except for my screen going blank after some minutes of inactivity.  this
never happened while I was watching a show, but if I walked away while
sitting at one of the menus, it would go blank.  I tried all the xorg
settings that people have suggested, but nothing worked.  because I was able
to recover the machine with the remote, I never pursued this any further.  I
also thought it might not be so bad for my plasma display if the screen went
blank after long periods of inactivity.

Fast forward to a week ago....

Since my next project is to build a new frontend machine, I needed to make
my existing backend have a static IP address.  At least, I think this is
necessary in order for the frontend to locate the backend consistently on
the same IP address.  Anyway, I made changes to my backend to switch from
DHCP to a static IP address.  This worked fine, but then my screen started
going blank, even if I was in the midst of watching a show.  Even worse, it
was not possible to recover with just the remote.  I had to go jiggle the
mouse, or tap the keyboard, to recover from the blank screen.  Very
annoying.  The WAF went down the tubes very quickly.

So, after reading this thread, I was able to fix the problem by following
this suggestion:

>>Or put the commands in either /etc/X11/xinit/Xsession or /etc/X11/
>>xinit/xinitrc, depending on whether you're using a graphical login or
>>booting in text mode and running 'startx'.

Again, no amount of fiddling with xorg.conf seems to do any good.

It sure looks like the original poster stumbled upon something similar to
what I saw, based on his comment

>>the only thing that I recall changing is installing a dhcp server and tftp
server (which uses xinetd) for use with my MediaMVP.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20080115/88fef98f/attachment.htm 

More information about the mythtv-users mailing list